Page MenuHomePhabricator

elementary: Efl.Ui.Select_Model should actually use iterator_new as prefix for all iterator functions.

Authored by cedric on Sep 20 2019, 3:25 PM.



This follow other API pattern in Efl, specifically every iterator API in eina.
Depends on D9960

Diff Detail

rEFL core/efl
Lint OK
No Unit Test Coverage
Build Status
Buildable 13492
cedric created this revision.Sep 20 2019, 3:25 PM

That name change sounds very good to me, @segfaultxavi @SanghyeonLee happy with it ? (I am.)

honestly, I don't know why selected_iterator_new should be exist as we have already fl.Ui.Multi_Selectable_Async.selected_items_get.
and if this name has to be changed like this,
I think we only need unselected_iterator_new
and efl.Ui.Multi_Selectable_Async.selected_items_get need to changed as selected_iterator_new?

I like iterator_new because it makes it very clear that the caller is responsible for freeing the iterator afterwards. This is true, right?

Also, @SanghyeonLee is correct, we need to rename Efl.Ui.Multi_Selectable. selected_items_get too.

cedric abandoned this revision.Sep 23 2019, 3:50 PM

Just realized that this two API could just be in multi async. Will merge that into the multi async patch and abandon this rename.