Page MenuHomePhabricator

efl_ui: rename efl_ui_types.eot to efl_ui_drag_types.eot

Authored by Jaehyun_Cho on Oct 14 2019, 5:59 AM.



The current efl_ui_types.eot contains only enum Efl.Ui.Drag_Dir.
Therefore, it is renamed to efl_ui_drag_types.eot as follows.
src/lib/efl/interfaces/efl_ui_types.eot -> efl_ui_drag_types.eot

Diff Detail

rEFL core/efl
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.
Jaehyun_Cho created this revision.Oct 14 2019, 5:59 AM

It seems that this patch has no reviewers specified. If you are unsure who can review your patch, please check this wiki page and see if anyone can be added:

Jaehyun_Cho requested review of this revision.Oct 14 2019, 5:59 AM
zmike added a subscriber: zmike.

efl_ui_types.eot can be renamed without issues.

efl_ui.eot I am not so sure about since we have stabilized some of these types, and thus the name efl_ui as an import seems like it should be stable in eolian now that eolian is stable...

Renamed efl_ui_types.eot to efl_ui_drag_types.eot only.

Jaehyun_Cho retitled this revision from efl_ui: rename efl_ui.eot and efl_ui_types.eot to efl_ui: rename efl_ui_types.eot to efl_ui_drag_types.eot.Oct 15 2019, 1:42 AM
Jaehyun_Cho edited the summary of this revision. (Show Details)
zmike accepted this revision.Oct 15 2019, 6:06 AM
This revision is now accepted and ready to land.Oct 15 2019, 6:06 AM
This revision was automatically updated to reflect the committed changes.

@zmike efl_ui.eot is the only Unified EOT file that does not follow the convention :/
I feel like we are losing the opportunity to right a wrong here.