Page MenuHomePhabricator

Unify "animated" flags

Authored by segfaultxavi on Nov 11 2019, 8:28 AM.



There exist several flags to indicate whether an object should be animated, with inconsistent names:
Efl.Canvas.Layout.animation: bool indicating if Edje animations should be played
Efl.Ui.Spotlight_Manager.animation_enabled: bool indicating if page transitions should be animated
Efl.Canvas.Animation_Player.animation: Efl.Canvas.Animation object

This commit unifies all of them: "animated" is now a flag, and "animation" is an object.

Note: Animation_Player is in the process of being replaced by an "animation" property in the
Efl.Canvas.Object, hence the need for non-clashing animation flags.

Test Plan

Builds and passes tests

Diff Detail

rEFL core/efl
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.
segfaultxavi created this revision.Nov 11 2019, 8:28 AM
segfaultxavi requested review of this revision.Nov 11 2019, 8:28 AM

Typo in commit message

I am very fine with this.

Just asking myself if it should be animated_transition or transition_animated but that is a detail we can bikeshed later on... :)

Adjectives come before nouns so... animated_transitions?

Okay, i just thought because we prefix here something with animation that is not in our animation mixin ... :) But as i said, i am fine with this :)

bu5hm4n accepted this revision.Nov 17 2019, 3:13 AM

I am going to merge this on the 20th of November, if there is no voice raised against this.

This revision is now accepted and ready to land.Nov 17 2019, 3:13 AM
Closed by commit rEFL9bb2df996642: Unify "animated" flags (authored by segfaultxavi, committed by Marcel Hollerbach <>). · Explain WhyNov 20 2019, 1:05 AM
This revision was automatically updated to reflect the committed changes.