It seems that this patch has no reviewers specified. If you are unsure who can review your patch, please check this wiki page and see if anyone can be added: https://phab.enlightenment.org/w/maintainers_reviewers/
Just two nitpicks...
I would rename this to sel_handler_enabled, for consistency with the property..
I know this is a bit unrelated to this patch, but this should probably be context_menu_enabled too, for consistency, and for clarity.