Layout_Factory is too narrow as the name for this class.
Our usage for the MVVM view-factory support
is not only for items, but also the contents such as
button, radio, image, check widget.
as it is generic factory for all Efl.Ui.Widget based object,
rename it to Generic_Factory,
and remove unnecessary method(theme_config).
This class is out of @beta,
but not released yet, targeted efl 1.24.
I think still we have the chance to change the name and re-stablizing it.