Page MenuHomePhabricator

ECORE_X_ATOM_NET_SUPPORTING_WM_CHECK property check always returns nonzero value. X server can be treated as unmanaged only when trying to get that property is failed i.e. it returns -1.
AbandonedPublic

Authored by devilhorns on Oct 5 2020, 5:25 AM.

Details

Reviewers
HarmlessBug

Diff Detail

Repository
rE core/enlightenment
Branch
harmlessbug
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 17362
Build 11624: arc lint + arc unit
HarmlessBug created this revision.Oct 5 2020, 5:25 AM
HarmlessBug requested review of this revision.Oct 5 2020, 5:25 AM

The logic is ok ... But I DONT like how this LOOKS....

managed = xyz_function.....
If !mananged goto town....

devilhorns requested changes to this revision.Oct 9 2020, 1:37 AM

I don;t like IT ....

managed = xyz...
if (!mananged) go Home

This revision now requires changes to proceed.Oct 9 2020, 1:37 AM

I would rather this LONG WINDED function be Properly returned, and Then Checked....Please make this code a little bit cleaner....

devilhorns added a comment.EditedOct 9 2020, 1:40 AM

We are trading One bad thing for just Another here ..... Please clean this UP properly.....then It will go In....

Happy to Aprovie this .. but it needs to Look better... Easier to Read.....

Get the return of the Function, Check that ... And then it Can Go In

Stop trying to make it More difficult to read...and just read it....

devilhorns added a comment.EditedOct 9 2020, 1:45 AM

It is all 0 & 1 right ?

Good report tho ....better than the average bear.....

Clean this up a little and I will put it in,..

Check Managed....

devilhorns added a comment.EditedOct 20 2020, 11:42 PM

Guess I will do it myself....make it proper, then submit it.....

No Answers from patch Author.....

Not hard to check a return/

devilhorns commandeered this revision.Nov 9 2020, 6:43 PM
devilhorns edited reviewers, added: HarmlessBug; removed: devilhorns.
devilhorns abandoned this revision.Nov 9 2020, 6:43 PM
raster added a subscriber: raster.Nov 10 2020, 1:15 AM

this isnt wrong.. it's just a bit ugly... maybe just managed -> int and if (managed > 0) in later if's... :)

this isnt wrong.. it's just a bit ugly... maybe just managed -> int and if (managed > 0) in later if's... :)

+100% agree !!!