Factorize the test infra.
Uniformize all the tests (function name convention)
The following test components have been refactored:
- Ecore, Ecore_Cxx, Ector
- Ecore_Con (maybe should be moved inside ecore test)
- Eet (split into different files)
- Eeze (also split)
- Efreet (needs more love!)
- Eina (minor changes: whitespaces, order of includes, ...)
- ElDbus, ElDbus_Cxx
- Eo (under suite/ only)
- Eolian, Eolian_Cxx
So far unmodified:
- efl_js, eolian_js
Thanks to this, setenv("CK_FORK", "no", 0); should become useless.
This patch should remove about 2K lines of duplicated code.