Radio inherits from Check now and remove the duplicate codes
- Should we reuse "changed" event of elm check in radio and define a macro
#define ELM_RADIO_EVENT_CHANGED ELM_CHECK_EVENT_CHANGED
but then it would be written in <widget>.c file. the same thing
which we were doing earlier. :/
Can eolian generate it? ;)
- In _elm_radio_eo_base_constructor()
should i change obj = eo_do_super_ret(obj, MY_CLASS, obj, eo_constructor()); to obj = eo_do_super_ret(obj, ELM_CHECK_CLASS, obj, eo_constructor()); ?
i think this is not required since this call actually makes the eo hierarchy so we should not break it.
aaaah. ok. changed. reality is this is a common event among so many widgets. this should have some interface to share - radios change, checks change, n state value things change, flipselectors change, spinners change, sliders change...
so what you are seeing now is one of those design things we'll hit as we go.
so this -> share interface in efl likely.
You can't really have a "changed" interface, because the changed should/would have different event info depending on what has changed. This is an example of a took generic naming that won't work any more. We would need to rename it to "state,changed" or whatever.
in all the changed events we have - there is no event info at all. it just says something changed - query the object for its current state to see what it is, so i'd disagree here. it is generic.