Page MenuHomePhabricator

ecore: make efl_loop_promise_new a function of Efl.Loop_Consumer.
AbandonedPublic

Authored by cedric on Dec 19 2018, 4:39 PM.

Details

Summary

I am not sure this is the right way to do it as binding would have to likely
to bind it manually.
Depends on D7491

Diff Detail

Repository
rEFL core/efl
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
cedric created this revision.Dec 19 2018, 4:39 PM
cedric requested review of this revision.Dec 19 2018, 4:39 PM
lauromoura accepted this revision.Dec 20 2018, 12:21 PM
This revision is now accepted and ready to land.Dec 20 2018, 12:21 PM
This revision was automatically updated to reflect the committed changes.
segfaultxavi added inline comments.
src/lib/ecore/efl_loop_consumer.eo
1

Hmmm... I now realize that we do not have a clear naming convention for callbacks. We have been using these two different conventions in our tree:

./src/lib/efl/interfaces/efl_ui_format.eo:function Efl.Ui.Format_Func_Cb
./src/lib/ecore/efl_threadio.eo:function EFlThreadIOCall

We should decide one and fix the others. I think it makes more sense the correctly namespaced one (Efl.Loop_Consumer_Promise_Cancel, for example). Will keep track of this in T7408.

bu5hm4n reopened this revision.Dec 26 2018, 3:26 AM
bu5hm4n added a subscriber: bu5hm4n.

I had to revert this, i can check repair the cnp error however, the conman thing is harder to check for me.

Additionally, should we make data_set a one shot function, so we can error out on calling twice to set the data ? On the one side this could be a ugly sideeffect that noone notices, and further more the data setted there is definitly lost and cannot be freed correctly.

src/lib/ecore_con/efl_net_control_technology-connman.c
402

data_set used after this.

src/lib/elementary/efl_selection_manager.c
250

data_set is used after that.

This revision is now accepted and ready to land.Dec 26 2018, 3:26 AM
bu5hm4n requested changes to this revision.Dec 26 2018, 3:26 AM
This revision now requires changes to proceed.Dec 26 2018, 3:26 AM
cedric abandoned this revision.Dec 28 2018, 9:47 AM

I am closing this review and we should move discussion to T7530.