Page MenuHomePhabricator

efl_gfx_image_animation_controller: Rename '*.Image_Animation_*' to '*.Frame_*'
ClosedPublic

Authored by jsuya on Jan 24 2019, 11:25 PM.

Details

Summary

Efl.Gfx.Image_Animation_Controller name refers to the control of an animatable image.
However, the method we use is closer to controlling the frame.
We can change the name to Efl.Gfx.Frame_Controller and enhance the functionality of the frame control.

Test Plan

N/A

Diff Detail

Repository
rEFL core/efl
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
jsuya created this revision.Jan 24 2019, 11:25 PM
jsuya requested review of this revision.Jan 24 2019, 11:25 PM

How about just efl_gfx_frame_controller ? (remove animation)

jsuya updated this revision to Diff 18937.Jan 27 2019, 8:58 PM

Update code
Efl.Gfx.Frame_Animation_Controller -> Efl.Gfx.Frame_Controller

jsuya updated this revision to Diff 18938.Jan 27 2019, 9:07 PM
jsuya retitled this revision from efl_gfx_image_animation_controller: Rename 'Image' to 'Frame' to efl_gfx_image_animation_controller: Rename '*.Image_Animation_*' to '*.Frame_*'.
jsuya edited the summary of this revision. (Show Details)

update commit message

jsuya updated this revision to Diff 18939.Jan 27 2019, 9:09 PM

remove unneccessary file

jsuya updated this revision to Diff 18940.Jan 27 2019, 9:18 PM

fix mistake

I think we could remove animated prefix here,

efl_gfx_frame_controller_frame_set()
efl_gfx_frame_controller_frame_count()
efl_gfx_frame_controller_loop_type()
efl_gfx_frame_controller_loop_count()
efl_gfx_frame_controller_frame_duration()

and animated() is not necessary since frame_count() is there.

jsuya updated this revision to Diff 18948.Jan 27 2019, 11:40 PM

update code

Please check comments.
we need replace all image objects to animated object in the doc.

src/lib/efl/interfaces/efl_gfx_frame_controller.eo
13

of frame based animated object interface.

30–31

animated object.

36

image object => animated object.

49

Get the total number of frames of the object, if animated.

55

animated image => animated object.

61

image object => animated object

63

image object => animated object

76

image object => animated object

92

image object =>object

jsuya updated this revision to Diff 18952.Jan 28 2019, 2:36 AM

update docs

jsuya marked 9 inline comments as done.Jan 28 2019, 2:41 AM

I agree Image is not correct, but I think Frame is too generic. It is not clear what it is being controlled by this class.
I liked Efl.Gfx.Animation_Controller. Are there any other opinions?

Hermet accepted this revision.Jan 28 2019, 10:51 PM
This revision is now accepted and ready to land.Jan 28 2019, 10:51 PM

@segfaultxavi
I agree to change if there is a more correct name.
But I do not think Efl.Gfx.Animation_Controller is correct.

I think controlling Animation is related to Play/Stop.
Efl.Player is an interface related to Play/Stop.

Hermet requested changes to this revision.Jan 28 2019, 10:55 PM

not yet confirmed

This revision now requires changes to proceed.Jan 28 2019, 10:55 PM

I agree Image is not correct, but I think Frame is too generic. It is not clear what it is being controlled by this class.
I liked Efl.Gfx.Animation_Controller. Are there any other opinions?

This class doesn't talk about animation, no play, no stop, pause, etc,
It's more similar to "a keyframe controller" for animation. it's a peripheral but basic functions for animation.

If you say "frame" is too generic, maybe true but it's not just frame but "Frame Controller" exactly.
I think there won't be any similar classes "Frame Controller" in GFX, That's why I bet on just "Frame Controller"

@segfaultxavi What do you think about my opinion?

I now understand Animation is not completely correct. I am OK with Frame.
Thanks @Hermet and @jsuya!

Hermet accepted this revision.Jan 29 2019, 2:16 AM
This revision is now accepted and ready to land.Jan 29 2019, 2:16 AM
This revision was automatically updated to reflect the committed changes.