Page MenuHomePhabricator

efl_canvas_scene: rename event from focus,* to scene_focus,*
ClosedPublic

Authored by bu5hm4n on Mar 7 2019, 1:31 PM.

Details

Summary

This event can just be renamed, no need to handle legacy. The reason for
this, that this event is used to map to EVAS_CALLBACK_ enum fields,
which means, the legacy names of the event does not matter.

ref T7476

Diff Detail

Repository
rEFL core/efl
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
bu5hm4n created this revision.Mar 7 2019, 1:31 PM
bu5hm4n requested review of this revision.Mar 7 2019, 1:31 PM
zmike requested changes to this revision.Mar 7 2019, 1:34 PM

I don't like using window in this context since this has nothing to do with a window. I think it should be canvas.

This revision now requires changes to proceed.Mar 7 2019, 1:34 PM

I would rather *not* us the term canvas. We don't have canvas arround in interfaces, what you have in the end is that you window has focus or not. The concept of a canvas is not part of the interfaces at all.

zmike added a comment.Mar 7 2019, 1:37 PM

If you're running in a framebuffer you don't have windows.

That does not really matter, a application developper has a handle to a window, and the window can either have focus or not. If this is now a event which is based on the canvas the scene or the rendering engine does not matter at all to such a dev.

zmike added a comment.Mar 7 2019, 1:40 PM

Why not just reuse scene ?

bu5hm4n updated this revision to Diff 20177.Mar 7 2019, 1:48 PM

make grumpy zmike happy zmike

cedric requested changes to this revision.Mar 7 2019, 2:24 PM
cedric added inline comments.
src/lib/efl/interfaces/efl_canvas_scene.eo
228

Maybe update the documentation too. I still would prefer canvas, because that is what this amalgamation of object are put on, but I am ok with scene at least it is in the name of the class.

This revision now requires changes to proceed.Mar 7 2019, 2:24 PM
bu5hm4n updated this revision to Diff 20282.Mar 8 2019, 2:30 AM

adjust docs

zmike retitled this revision from efl_canvas_scene: rename event from focus,* to window_focus,* to efl_canvas_scene: rename event from focus,* to scene_focus,*.Mar 8 2019, 5:49 AM
zmike accepted this revision.Mar 8 2019, 6:02 AM
This revision was not accepted when it landed; it landed in state Needs Review.Mar 8 2019, 6:08 AM
Closed by commit rEFLa007badbed39: efl_canvas_scene: rename event from focus,* to scene_focus,* (authored by Marcel Hollerbach <mail@marcel-hollerbach.de>, committed by zmike). · Explain Why
This revision was automatically updated to reflect the committed changes.