Page MenuHomePhabricator

csharp: Remove warning about clashing GetType() methods
ClosedPublic

Authored by lauromoura on Mon, Apr 15, 9:32 AM.

Details

Summary

This changes the naming scheme to replace GetType/SetType methods
with Get<CLASS>Type/Set<CLASS>Type. Like GetGestureType.

Avoids cs compiler complaining of clashing with System.Object.GetType.

Fixes T7727

Diff Detail

Repository
rEFL core/efl
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
lauromoura created this revision.Mon, Apr 15, 9:32 AM
lauromoura requested review of this revision.Mon, Apr 15, 9:32 AM
vitor.sousa accepted this revision.Mon, Apr 15, 12:28 PM
This revision is now accepted and ready to land.Mon, Apr 15, 12:28 PM
This revision was automatically updated to reflect the committed changes.

Since @segfaultxavi is the one that suggested this rule.
I'm confident he is OK with this push :D