Page MenuHomePhabricator

efl_gesture: Delete prefix efl_canvas_gesture -> efl_gesture.
AbandonedPublic

Authored by CHAN on May 23 2019, 9:15 PM.

Details

Summary

gesture manager doesn't need 'canvas' prefix.

Diff Detail

Repository
rEFL core/efl
Branch
arcpatch-D9017
Lint
No Linters Available
Unit
No Unit Test Coverage
Build Status
Buildable 11634
Build 8720: arc lint + arc unit
CHAN created this revision.May 23 2019, 9:15 PM

It seems that this patch has no reviewers specified. If you are unsure who can review your patch, please check this wiki page and see if anyone can be added: https://phab.enlightenment.org/w/maintainers_reviewers/

CHAN requested review of this revision.May 23 2019, 9:15 PM
CHAN edited the summary of this revision. (Show Details)May 23 2019, 9:44 PM
CHAN added reviewers: Jaehyun_Cho, Hermet, woohyun.

@CHAN
This causes build error with --enable-csharp-bindings.
Because Efl.Canvas.Gesture becomes Efl.Gesture and we already have Efl.Gesture.Events.
Efl.Gesture was a namespace in C# but now it becomes a class as well.

To resolve this issue, we have 2 options.

  1. Efl.Gesture -> Efl.Gesture.Object

or

  1. Efl.Gesture.Events -> Efl.Gesture_Events

Do you think which one is better? Or is there any other option for this issue?

CHAN updated this revision to Diff 22456.May 26 2019, 10:06 PM

Fix C# build error.

CHAN added a comment.May 26 2019, 10:08 PM

@Jaehyun_Cho

Thanks. i check the C# build pass through the second way meson build as well.

segfaultxavi requested changes to this revision.May 27 2019, 12:59 AM
segfaultxavi added subscribers: bu5hm4n, zmike, segfaultxavi.

@CHAN Why do you think Efl.Canvas.Gesture does not need the Canvas prefix? Gestures seem related to the Canvas to me.

If the C function name is too long, you can always use the c_prefix to shorten it.

I prefer not like adding classes to the top-level Efl namespace, unless there is a good reason...

What do you think @zmike , @bu5hm4n @cedric ?

This revision now requires changes to proceed.May 27 2019, 12:59 AM
CHAN added a comment.May 28 2019, 2:57 AM

@segfaultxavi

Thanks for giving your opinion here.

It is not meant to be reduced the API name.

Of course, the gesture event is dependent on the canvas,
but it does not do anything to the canvas and does not draw on the canvas, so the canvas prefix is not needed i think.

If this is independent from the canvas, what do you think of moving it to Efl.Input ?

If this is independent from the canvas, what do you think of moving it to Efl.Input ?

Oh! that's a very good suggestion, I agree with @bu5hm4n here.

CHAN abandoned this revision.May 30 2019, 3:25 AM

For this Input prefix looks more meaningful.
But When i add Input prefix for gesture manager.
It looks implementing efl_input_types and events, Actually not though.
I think it is confusing to use.

So Let's leave it.