Page MenuHomePhabricator

elm_test/ui.bg: use full white+opaque for unchecked 'bg color' state
ClosedPublic

Authored by zmike on Jun 3 2019, 9:01 AM.

Details

Summary

using 0,0,0 (black) with 0 alpha (transparent) here causes the clipper for the
image to draw a fully transparent rectangle, which means that no pixels for
the clipped image are visible.

the expectation when using this test is that enabling the bg color will shade
the image with a red tint, and disabling the bg color will return the image to
its normal color. the current version of this test gives the impression that
disabling the color setting on this widget breaks the widget, which is not
accurate. currently.

fix T7984

Diff Detail

Repository
rEFL core/efl
Lint
Automatic diff as part of commit; lint not applicable.
Unit
Automatic diff as part of commit; unit tests not applicable.
zmike created this revision.Jun 3 2019, 9:01 AM

It seems that this patch has no reviewers specified. If you are unsure who can review your patch, please check this wiki page and see if anyone can be added: https://phab.enlightenment.org/w/maintainers_reviewers/

zmike requested review of this revision.Jun 3 2019, 9:01 AM
devilhorns accepted this revision.Jun 3 2019, 9:12 AM
devilhorns added a subscriber: devilhorns.

Change looks good, but I did not test for accuracy ... I assume you know how to set colors properly ;)

This revision is now accepted and ready to land.Jun 3 2019, 9:12 AM
This revision was automatically updated to reflect the committed changes.