Page MenuHomePhabricator

Rename orientation -> image_orientation.

Authored by eagleeye on Jul 11 2019, 9:43 PM.



Efl.Gfx.Image_Orientable and Efl.Ui.Layout_Orientable have same property name.
So when class extends both interfaces, it makes conflict.

Relates to T7924

Diff Detail

rEFL core/efl
Automatic diff as part of commit; lint not applicable.
Automatic diff as part of commit; unit tests not applicable.
eagleeye created this revision.Jul 11 2019, 9:43 PM
eagleeye requested review of this revision.Jul 11 2019, 9:43 PM
eagleeye edited the summary of this revision. (Show Details)Jul 11 2019, 9:47 PM
eagleeye added a reviewer: segfaultxavi.
segfaultxavi accepted this revision.Jul 12 2019, 1:31 AM

Makes sense, builds and passes tests, and allows scrollbar to inherit both from Layout_Orientable and Image_Orientable.

Thanks for this patch. For consistency, could you also rename Efl.Ui.Layout_Orientable.orientation to layout_orientation?

This revision is now accepted and ready to land.Jul 12 2019, 1:31 AM
Closed by commit rEFL7d33cf977f51: Rename orientation -> image_orientation. (authored by Hosang Kim <>, committed by segfaultxavi). · Explain WhyJul 12 2019, 1:32 AM
This revision was automatically updated to reflect the committed changes.