Page MenuHomePhabricator

minimized windows restoring themselves automagically
Closed, ResolvedPublic

Description

https://phab.enlightenment.org/file/info/PHID-FILE-cdybco5pje7iokns5hun/

Sorry for the horrible quality. What I'm doing is minimizing Terminology, and then minimizing other windows I had open, but terminology will come right back up afterwards. It seems to happen with any window.

I will clear my .e/ and then test again...

Enlightenment : 0.18.99.18103.8483a3c-1
EFL : 1.9.99.24838.c2bdda6-1
Elementary : 1.9.99.9550.6a3db30-1

abyomi0 created this task.Mar 9 2014, 3:16 PM
abyomi0 updated the task description. (Show Details)
abyomi0 raised the priority of this task from to Incoming Queue.
abyomi0 added a project: enlightenment-git.
abyomi0 updated the task description. (Show Details)
abyomi0 added a subscriber: abyomi0.
abyomi0 closed this task as Resolved.Mar 9 2014, 3:48 PM
abyomi0 claimed this task.

Deleted .e/

Problem seems to have disappeared.

abyomi0 updated the task description. (Show Details)Mar 9 2014, 3:48 PM
abyomi0 reopened this task as Open.EditedJun 5 2014, 8:08 PM

This has appeared in enlightenment-git 0.19.0.18490.d26dee5-1...with a completely new profile!

efl-git : 1.10.99.25932.82b8528-1

{F9937}

Reproduction

  1. Have two windows open, a terminal and file manager, or whatever you like.
  2. Maximize both windows (have both windows open above each other...)
  3. Minimize first window
  4. Minimize second window
  5. Minimize other window that comes up
  6. ...
abyomi0 removed abyomi0 as the assignee of this task.Jun 7 2014, 10:17 AM
abyomi0 triaged this task as Normal priority.Jun 7 2014, 8:58 PM
zmike edited this Maniphest Task.Jun 8 2014, 9:32 AM
zmike closed this task as Resolved.Jun 8 2014, 9:32 AM

Closed by commit rE5ad876ccad4c.

abyomi0 reopened this task as Open.EditedAug 18 2014, 6:47 PM

This is odd. It happens...with a completely new profile made a few days ago...

It isn't as easily reproduced (at least I think). I have Chromium, Settings, Mouse Bindings, Terminator, and mpv open.

Just as easily reproduced. You need a minimum of two windows. Minimizing Chromium and then Terminator causes Chromium to come back up.

Version

Enlightenment : 0.19.0.18670.c006bbf-1
EFL : 1.11.0beta2.27179.396433b-1

abyomi0 assigned this task to zmike.Aug 19 2014, 3:26 PM

It's back. Somehow.

abyomi0 closed this task as Resolved.Aug 23 2014, 9:08 PM

abyomi0 reopened this task as Open.Sep 16 2014, 4:01 PM

It's back.

  1. Open two windows, maximize them over one another
  2. Minimze one window, minimize the other window
  3. First window comes back up.

E 0.19.0.18886.0e19d32

abyomi0 added a comment.EditedSep 18 2014, 5:15 PM

With Tasks...

  1. Open Terminator
  2. Modify the window to maximize horizontally right
  3. Open Opera
  4. Keep Terminator open, above Opera
  5. Using the mouse wheel on Tasks, iconfiy Opera, then iconfiy Terminator the same way

Result : Opera comes back up.

Discovered Extras

When I do the above, and if Opera is raised (manually or automagically) Opera stops receiving keyboard input, until I alt-tab to another window and back to Opera again. Or by switching virtual desktops. This is easily noticeable on Phab when adding a comment, because even though the comment box is outlined with a thin blue shadow, nothing you type shows up there.

Name : efl-git
Version : 1.11.99.27789.68ed5a6-1
Build Date : Fri 19 Sep 2014 12:37:36 PM EDT
Name : elementary-git
Version : 1.11.99.10614.c34706d-1
Build Date : Fri 19 Sep 2014 12:51:26 PM EDT
Name : enlightenment-git
Version : 0.19.99.18952.98457f7-1
Build Date : Fri 19 Sep 2014 02:18:01 PM EDT

zmike lowered the priority of this task from Normal to Trivial.Sep 23 2014, 7:34 AM

Not seeing it.

abyomi0 closed this task as Invalid.Sep 23 2014, 1:25 PM

Moved my profile and started with a new one, and the issue went away.

Since I build E straight from git, I was wondering if you could tell me if I should start with a new profile every time I rebuild or if it is safe to keep to keep the old profile around.

I usually rebuild every Friday.

zmike added a comment.Sep 23 2014, 1:39 PM

I haven't reset my config since before E18 release. If your config needs a reset, it will be reset.

abyomi0 added a comment.EditedSep 23 2014, 4:11 PM

Hmm. I remember the first time this was fixed, I rebuilt, tested and it occurred then, but just before I reopened this I wiped out my config and it stopped.

Oddly enough, if I switch back to my original config it happens again, just as described.

Would it be helpful if I uploaded my config?
Any files specifically you would need from the .e/e ?

Hm. I still see this, since I've kept my original profile.
But, I've just had a look through the available options, and I'm not seeing anything that would affect minimization/iconify.

abyomi0 added a comment.EditedJan 12 2015, 12:34 PM

Would this be helpful? It's my config.

F12825

Somehow, I managed to trigger this when I was launching firefox.

Create another firefox profile.

  1. Open a blank LibreOffice Writer page and minimize it.
  2. Launch firefox through its icon, select a profile

After the profile selection window disappears, LibreOffice will raise itself.

Name : elementary-git
Version : 1.14.0alpha1.11328.ee7d542-1
Build Date : Fri 10 Apr 2015 12:40:15 PM EDT
Install Date : Fri 10 Apr 2015 12:42:00 PM EDT

Name : efl-git
Version : 1.14.0alpha1.30078.1438a98-1
Build Date : Sun 12 Apr 2015 09:39:38 PM EDT
Install Date : Sun 12 Apr 2015 09:41:11 PM EDT

Name : enlightenment-git
Version : 0.19.99.19797.95d7012-1
Build Date : Fri 10 Apr 2015 12:48:01 PM EDT
Install Date : Fri 10 Apr 2015 12:50:10 PM EDT

abyomi0 reopened this task as Open.Apr 14 2015, 7:08 AM
abyomi0 added a subscriber: Merlin.Apr 30 2015, 7:11 PM
abyomi0 raised the priority of this task from Trivial to Normal.Apr 30 2015, 7:16 PM
zmike added a comment.May 1 2015, 10:25 AM

I tested this using your config and reproduction steps and saw nothing unusual. It would be helpful if you could trigger this and send me a backtrace from a breakpoint on e_client_unmaximize().

abyomi0 changed the visibility from "All Users" to "Public (No Login Required)".May 12 2015, 12:52 PM

I've never gotten a backtrace from a breakpoint before.
I'm not exactly sure how to go about it.
trying to run e from gdb doesn't work. setting the breakpoint while E is running doesn't do produce anything either.

This is what I did :
gdb enlightenment 1577
set logging file logs/e_client_max.log
set logging on
break e_client_unmaximize

then I go to reproduce this and while I can reproduce it, nothing shows up in gdb.

zmike added a comment.May 12 2015, 2:05 PM

I've never gotten a backtrace from a breakpoint before.
I'm not exactly sure how to go about it.
trying to run e from gdb doesn't work. setting the breakpoint while E is running doesn't do produce anything either.

This is what I did :
gdb enlightenment 1577
set logging file logs/e_client_max.log
set logging on
break e_client_unmaximize

then I go to reproduce this and while I can reproduce it, nothing shows up in gdb.

kill -SIGUSR1 $(pidof enlightenment)
gdb --pid=$(pidof enlightenment)
set logging file logs/e_client_max.log
set logging on
break e_client_unmaximize
comm 1
bt
c
end
c

This will fill your log file with backtraces of every call to e_client_unmaximize.

abyomi0 added a comment.EditedMay 12 2015, 2:48 PM

I can run all those commands just fine.
Then, I go to reproduce this. Minimizing multiple thunar windows will trigger this bug, but nothing showed up in the log. Then, I decided to un-maximize from the window menu and e segfaulted. Nothing in the log besides :

Breakpoint 1 at 0x459312
Type commands for breakpoint(s) 1, per line. 
End with a line saying just "end". 
(I run commands...)
Continuing.

Program terminated with SIGSEGV, Segmentation fault. 
The program no longer exists.
zmike added a comment.May 12 2015, 2:53 PM

What is "I run commands" ?

In T1069#32057, @zmike wrote:

What is "I run commands" ?

That's the bit where I would everything after comm 1

zmike added a comment.May 12 2015, 3:08 PM

You would run all of the commands at once, not split.

abyomi0 added a comment.EditedMay 16 2015, 9:05 AM

This is what I'm doing...(which is probably wrong?)

The crash is unintentional.

I need to get back to getting useful information for this...

zmike added a comment.Sep 21 2015, 2:52 PM

Amazingly it happened immediately when I tested it today.