Page MenuHomePhabricator

Focus issue when switching with Alt-Tab
Closed, InvalidPublic

Description

I'm not sure if it's related to T708.

The issue starts at about 20 seconds. View the file. {F9021}
When I open the Terminology tab, I'm trying to launch vim, but Terminology is not accepting the keyboard input. Then I switch between applications and Terminology starts accepting my input.
This issue isn't limited to Terminology.
The..."decoration" of the titlebar also goes gray (instead of staying black...) when I mouse up to it. I didn't capture that in the video though.

@zmike, I would like to try save you the trouble of attempting to reproduce this issue.
How can I get output (in the left most window) like this? http://i.imgur.com/Hutcpcm.png

Would keeping my .e/ directory cause a problem like this?

I built E and EFL from the AUR, my /etc/makepkg.conf is modified.{F9022}

@raster, is this similar to T708?
Also, is having the Debug CFLAGS enough? I shouldn't have to pass that flag in the PKGBUILD since it's already in my /etc/makepkg.conf, right?

Rebuilt E and EFL, issue persists, built with no modifications to my the CFLAGS /etc/makepkg.conf, this time.
(Check the Task history for the versions I had installed earlier.)

Arch Linux : 3.13.8-1-ARCH

Name : enlightenment-git
Version : 0.18.99.18242.dc05d96-1
Build Date : Tue 01 Apr 2014 12:18:24 AM EDT
Install Date : Tue 01 Apr 2014 12:18:54 AM EDT

Name : efl-git
Version : 1.9.99.25119.c556421-1
Build Date : Tue 01 Apr 2014 12:03:07 AM EDT
Install Date : Tue 01 Apr 2014 12:03:45 AM EDT

Related Objects

Mentioned In
Debugging
abyomi0 created this task.Mar 31 2014, 5:22 PM
abyomi0 updated the task description. (Show Details)
abyomi0 raised the priority of this task from to Incoming Queue.
abyomi0 updated the task description. (Show Details)
abyomi0 added a subscriber: abyomi0.
abyomi0 updated the task description. (Show Details)Mar 31 2014, 5:40 PM
abyomi0 added a project: enlightenment-git.
abyomi0 added subscribers: raster, zmike.
abyomi0 changed the visibility from "All Users" to "Public (No Login Required)".Mar 31 2014, 7:40 PM
abyomi0 updated the task description. (Show Details)Apr 1 2014, 7:21 AM
abyomi0 changed the edit policy from "All Users" to "abyomi0 (Yomi)".
abyomi0 renamed this task from Focus issue to Focus issue when switching with Alt-Tab.Apr 1 2014, 9:51 AM
abyomi0 updated the task description. (Show Details)Apr 1 2014, 12:03 PM
abyomi0 updated the task description. (Show Details)Apr 1 2014, 12:14 PM
abyomi0 updated the task description. (Show Details)Apr 1 2014, 2:18 PM
zmike closed this task as Invalid.Apr 2 2014, 7:13 AM
zmike claimed this task.
zmike added a subscriber: seoz.

You've cleverly changed the edit mode of this task, so I will be equally clever and close it as invalid instead of editing it for you.

  • STOP EDITING YOUR TASKS SO MANY TIMES. Seriously. We get emails every time someone edits a task, I don't need 30 mails from one guy who can't put a little thought into the first draft of an issue.
  • This is an Elementary bug due to the recent focus feature that @seoz put in. It has nothing to do with E.
abyomi0 changed the edit policy from "abyomi0 (Yomi)" to "All Users".Apr 8 2014, 5:20 PM