Page MenuHomePhabricator

E crashed when fullscreening mpv
Closed, InvalidPublic

Description

I don't think I can find a proper way to reproduce this, but I have a backtrace FWIW.

I was watching this :

mpv --vo=opengl --hwdec=vaapi https://www.youtube.com/watch?v=u6PXba8X6N8

I tried to fullscreen mpv but instead it went borderless but wouldn't fullscreen.
Like this : {F9826}
After trying to fullscreen repeatedly, E eventually crashed.

Backtrace : {F9825}

Versions :
Name: enlightenment-git
Version: 0.18.99.18467.60aee8d-1

Name : efl-git
Version : 1.10.99.25878.328d28a-1

Name : xf86-video-intel
Version : 2.99.911-2

abyomi0 created this task.May 31 2014, 1:24 PM
abyomi0 updated the task description. (Show Details)
abyomi0 raised the priority of this task from to Incoming Queue.
abyomi0 added a project: enlightenment-git.
abyomi0 changed the visibility from "All Users" to "Public (No Login Required)".
abyomi0 added a subscriber: abyomi0.
abyomi0 updated the task description. (Show Details)May 31 2014, 1:39 PM
abyomi0 updated the task description. (Show Details)May 31 2014, 8:40 PM
zmike triaged this task as Trivial priority.Jun 2 2014, 6:14 AM
zmike added a subscriber: zmike.

Needs valgrind.

abyomi0 added a comment.EditedJun 2 2014, 9:04 PM

So while I was fooling around with mpv and vo's I managed to get E to crash again...but I wasn't in a valgrind session.

If I'm supposed to get a proper valgrind log (since I'll be going through Xephyr, right?) how am I to do that when E falls back to software rendering?

mpv won't allow VDPAU via Xephyr, fails with this :

mpv --vo=vdpau --hwdec=vdpau https://www.youtube.com/watch?v=u6PXba8X6N8
Playing: https://www.youtube.com/watch?v=u6PXba8X6N8
[quvi] Checking URL...
[cache] Cache size set to 25000 KiB
Detected file format: QuickTime / MOV (libavformat)
File tags:
 major_brand: mp42
 minor_version: 0
 compatible_brands: isommp42
 creation_time: 2014-03-07 05:19:07
[stream] Video (+) --vid=1 (*) (h264)
[stream] Audio (+) --aid=1 --alang=und (*) (aac)
Xlib:  extension "NV-GLX" missing on display ":1.0".
Xlib:  extension "NV-GLX" missing on display ":1.0".
[vo/vdpau] Error when calling vdp_device_create_x11: 1
Error opening/initializing the selected video_out (-vo) device.
Video: no video
Video: no video
abyomi0 closed this task as Invalid.EditedJun 2 2014, 9:53 PM
abyomi0 claimed this task.

Closing. I must've been doing something really stupid and changed

Don't composite full screen windows

On and off a few times and then full screened mpv, causing E to crash.

Man, the failure. =_=

abyomi0 added a comment.EditedAug 17 2014, 8:40 AM

This happened again, although only once and the only thing I have is a backtrace.

I should note that this is on completely different hardware.
An AMD laptop, using enlightenment-git, efl-git, and mesa 10.2 (iirc...)

This seems to happen very rarely.