Page MenuHomePhabricator

Getting impatient with Connection Manager causes E to crash!
Closed, ResolvedPublic

Description

Reproduction

# Join wireless network
# Before wireless network is joined, switch...

Wait wait. Even better...

  1. Switch wireless networks like a madman. (Either unsecured (I think) or that you have the passphrases to...I was only able to test with secured networks.)
  2. Dat WBOD.
  3. Oh noes.

Also, after the crash, the interface will go down. On this laptop, you know wireless is on when the LED is green. When Connection Manager crashes, the LED goes off.

A wild backtrace appears!

{F9850}

abyomi0 created this task.Jun 2 2014, 10:53 PM
abyomi0 updated the task description. (Show Details)
abyomi0 raised the priority of this task from to Incoming Queue.
abyomi0 added projects: enlightenment-git, Restricted Project.
abyomi0 changed the visibility from "All Users" to "Public (No Login Required)".
abyomi0 added a subscriber: abyomi0.
abyomi0 updated the task description. (Show Details)Jun 2 2014, 11:15 PM
zmike added a subscriber: zmike.Jun 3 2014, 2:30 AM

@abyomi0 used backtrace! It's not very effective...

@zmike used valgrind log! @zmike does not have valgrind log...

abyomi0 added a comment.EditedJun 3 2014, 6:15 AM

I used the Debugging page, but when I do
valgrind --tool=memcheck --db-attach=yes enlightenment_start
and switch over to the X Server, all I get is a black screen and a mouse.
It appears that the iBar is there, I just can't see it, I know its there because I can raise brightness.

@abyomi0 learned Search !
@abyomi0 learned enlightenment --help and enlightenment_start --help !
@abyomi0 forgot Debugging !

abyomi0 triaged this task as Trivial priority.Jun 7 2014, 9:02 PM
kuuko added a subscriber: kuuko.Jul 16 2014, 2:25 AM

@abyomi0 Did you get that valgrinding done? Sounds like connman itself crashes, taking E with it.

I tried, but I couldn't get it to crash inside valgrind. :-\

it could be related. i start econn with econnman-bin -a.

I try to connect to a EAP: PEAP network, with a none Phase 2. I get "invalid arguments" and log below.

Log:
Traceback (most recent call last):

File "object.pyx", line 343, in efl.elementary.object._object_callback (efl/elementary/object.c:7667)
File "/usr/bin/econnman-bin", line 728, in _item_selected
  self.on_selected(path, s)
File "/usr/bin/econnman-bin", line 1428, in connect_service
  if ("ieee8021x" in sec) and not config_exists(name):
File "/usr/bin/econnman-bin", line 319, in config_exists
  if config_get(name):
File "/usr/bin/econnman-bin", line 304, in config_get
  config_file_setup()
File "/usr/bin/econnman-bin", line 262, in config_file_setup
  fd = open(CONF_FILE, 'r', encoding='utf8')

TypeError: 'encoding' is an invalid keyword argument for this function
Traceback (most recent call last):

File "object.pyx", line 343, in efl.elementary.object._object_callback (efl/elementary/object.c:7667)
File "/usr/bin/econnman-bin", line 1383, in _on_eap_method
  config_set(self.name, "EAP", eap_val)
File "/usr/bin/econnman-bin", line 298, in config_set
  config_write(name)
File "/usr/bin/econnman-bin", line 327, in config_write
  with open(CONF_FILE, 'w', encoding='utf8') as configfile:

TypeError: 'encoding' is an invalid keyword argument for this function
Traceback (most recent call last):

File "object.pyx", line 343, in efl.elementary.object._object_callback (efl/elementary/object.c:7667)
File "/usr/bin/econnman-bin", line 1395, in _on_phase2
  config_set(self.name, 'Phase2', phase2_val)
File "/usr/bin/econnman-bin", line 298, in config_set
  config_write(name)
File "/usr/bin/econnman-bin", line 327, in config_write
  with open(CONF_FILE, 'w', encoding='utf8') as configfile:

TypeError: 'encoding' is an invalid keyword argument for this function
No handlers could be found for logger "root"

kuuko added a comment.Sep 3 2014, 6:42 PM

@winner8 Not related, you have an old git version which had an incompatibility with Python 2 in the PEAP code that has been added after the latest release version.

abyomi0 closed this task as Resolved.EditedJul 18 2015, 3:03 PM
abyomi0 claimed this task.

Might just be easier to not go nuts when using econnman.