Page MenuHomePhabricator

Window Switcher focus glitch
Closed, ResolvedPublic

Description

When I Alt+Tab from Chromium to LibreOffice, LibreOffice stays transparent, but is actually focused.

Here's a video.

{F10726}

abyomi0 created this task.Jul 30 2014, 5:08 PM
abyomi0 updated the task description. (Show Details)
abyomi0 raised the priority of this task from to Normal.
abyomi0 assigned this task to zmike.
abyomi0 added a project: enlightenment-git.
abyomi0 changed the visibility from "All Users" to "Public (No Login Required)".
abyomi0 added a subscriber: abyomi0.
abyomi0 added a comment.EditedAug 4 2014, 9:05 AM

This also seems to happen even if Composite-Focus Out Color is off.

It only appears to affect composite focus color out, but whatever this is makes the glitch more noticeable.

Is there a setting somewhere that I've overlooked?

abyomi0 renamed this task from Composite Focus-out Color glitch to Window Switcher glitch.Aug 12 2014, 8:22 PM
abyomi0 renamed this task from Window Switcher glitch to Window Switcher focus glitch.Aug 18 2014, 3:26 PM
abyomi0 added a comment.EditedSep 9 2014, 11:37 AM

This seems to have become slightly different.
I'll elaborate when I get the chance.

Still the same.
You need about 4 windows open to reproduce it.

This seems to be related to the options for window switching.
If I have both Warp mouse while selecting and Warp mouse at end, then I run into the issue as shown in the recording up above.

I don't know why both were set...perhaps there should be a warning when both options are enabled?
"If both of these options for Selecting are enabled at the same time, window switching will be broken for until one of the options is disabled. Do not report a bug."

zmike edited this Maniphest Task.Nov 28 2014, 12:08 PM
zmike closed this task as Resolved.Nov 28 2014, 12:08 PM

Closed by commit rE50f5b74cd8a7.

zmike edited this Maniphest Task.Nov 28 2014, 12:08 PM
abyomi0 reopened this task as Open.Jan 20 2015, 11:32 AM

New profile.

These my Window Switcher settings

I think it might have something to do with Warp mouse while selecting...because (as of now) with it off, I don't see this.

I'm not sure if this is related to this Task, but I've noticed that now when I alt-tab (sometimes) to other windows, the window behind the one I switched to will get focus. It reminds me of this and T1546...

zmike added a comment.Jul 7 2015, 10:19 AM

This is probably fixed as of yesterday.

abyomi0 closed this task as Resolved.Jul 7 2015, 10:36 AM

It would seem so. Thanks.