Page MenuHomePhabricator

Enlightenment SEGV'd when attempting to select Custom Wallpaper for lock screen
Closed, ResolvedPublic

Description

Reproduction

  1. Go to lock screen settings
  2. Then to wallpaper tab
  3. Click on Custom, then click on the empty gray box.
  4. BAM! SEGV'd.

Here's a backtrace...and soon, a valgrind log...
{F10747}

Related Objects

abyomi0 created this task.Aug 1 2014, 10:25 AM
abyomi0 updated the task description. (Show Details)
abyomi0 raised the priority of this task from to High.
abyomi0 assigned this task to zmike.
abyomi0 added a project: enlightenment-git.
abyomi0 changed the visibility from "All Users" to "Public (No Login Required)".
abyomi0 added a subscriber: abyomi0.
abyomi0 edited this Maniphest Task.Aug 1 2014, 10:25 AM
huchi added a subscriber: huchi.Aug 2 2014, 6:29 AM

Actually, I couldn't reproduce it. Anyhow, I fixed suspicious code based on your backtrace.
https://git.enlightenment.org/core/a.git/commit/?id=e2daed517729e70c5b4e6d57aae5df69b487e8d5

Could you check whether it's fixed or not?

abyomi0 lowered the priority of this task from High to Trivial.Aug 2 2014, 1:39 PM

I should be able to test later this tonight or tomorrow, at the latest.

abyomi0 closed this task as Resolved.EditedAug 2 2014, 4:45 PM

It works.
Doesn't crash anymore.