Page MenuHomePhabricator

Bugs and problems found during initial configuration
Closed, ResolvedPublic

Description

Because I can now run Enlightenment I have configured it until I was satisfied.
Overall it is working quite good (at least better than Gnome did) but there are still a lot of issues.
In the coming weeks I may not have the time to investigate them further so I have written them down in one big text instead of splitting them up into individual bug reports.
Also: I am not sure how many of them are actual bugs.

Personal Application Launcher: Once a personal Application has been created (points to a shell script, icon has been added) there is no way to access the launcher except by "Run everything". If added to the favorites menu, it does not show up. It is visible in the Favorite Applications configuration but not in the actual menu. Neither is it visible in any of the "Applications" menus.
Severity: Makes the Personal Application Launcher feature useless in most if not all situations.

File selection dialog: When I opened the file selection dialog when creating a personal application launcher I noticed that the dialog is not resizable. Depending on the user's settings this can be annoying. In my case the directory section was already so small that I wanted to enlarge it.
Severity: Annoying but probably non-critical

Keyboard Settings: After I added a new layout, the "Apply" button is still grey, suggesting that it has automatically been applied once the new layout was selected. It wasn't, the new layout does not show up in the bar. I have to do some additional change so that "Apply" becomes pushable.
Severity: Newbie trap but easily bypassed.

File Manager: File Properties does not show anything under "Name", "Location" etc., just empty lines.
Besides that: When in "List" view mode, the size of the files is not shown. Unsure if bug or feature.
Severity: Minor

Language Setting: Changing the language setting is impossible. "Apply" is always greyed out. Probably related to the "Keyboard Settings" but, but I have not found a workaround.
Severity: Makes feature useless.

Clock: Date lists month first and day second. I realize this is how it is handled in some countries so I may be able to change that behaviour by choosing a different locale. However, I can't test this because I can't change the language settings due to the bug above.
Severity: Minor

GTK-Fonts: The menu fonts on all gnome applications are small and very ugly. It seems many people have encountered this problem before, but the workarounds that I have seen on the internet seem to be outdated. I tried starting the gnome-settings-daemon, but then my mouse cursor vanishes.
I realize that this is probably not an Enlightenment problem but an easy solution (preferably standard) should be given to people like me that move from Gnome to E. Enlightenment should not be associated with "ugly".
Severity: Non-critical but VERY annoying.

Mixer: It is very unintuitive and limited. When I open the mixer I expect to change the output card by clicking on it. Instead all it does is giving me a volume control specific to that card. The main slider on the widget did not change to that output card, although I would expect it to. To do that I had to enter the Mixer settings menu. And I can't change my output card there either, I can just reassign the volume slider.
I understand that this tool is probably low priority, but I think it shouldn't be because can give a strong negative first impression to new users.
As it is now, I have to use a separate application for audio control. (pavucontrol, which doesn't show up in my favourites menu either, although I have assigned it to it using the window bar)
Severity: Irrelevant since I have found the "Death to Mixer" ticket.

Terminology: Does not seem to support japanese input. I installed ibus-anthy and it works with jedit, libreoffice and the gnome-terinal. But no japanese import is possible in Terminology
Severity: Depends strongly on the user.

Enlightenment: I have occasional problems with the responsiveness of E after starting. I am not really surprised: I have already had problems with my grafics configuration. get-edid fails to detect my monitor with my current grafics card and because of that I had to create my own xorg.conf so that I can access the huge 2560x1440 resolution (on a Radeon R7 250 card with free drivers on Debian testing). Gnome had problems with it, giving me full resolution but leaving most of the screen black. The consoles have problems with it, giving me different resolutions with each computer start.
I configured E to use that big resolution and switched to OpenGL display since contrary to 2D, which gives me occasional problems, I have no problems at all with OpenGL. When I start E, the following things can happen:

  • It starts, quickly blacks out and returns one or two times. It is quickly available in full health.
  • It starts but for one or two minutes it has bad responsiveness. I can do something for half a second, then it hangs for about two seconds. After a couple of minutes the screen blacks and returns. After that, it is fully usable.
  • I only get to the background screen. My bottom shelf displays one app or two and then stops. It does not seem to recover from that. If I give a keyboard command to quit E, it can take a couple of minutes until it actually does that.

Thankfully, the flawless start is by far the most common.
Severity: Unknown. Probably only my personal problem.

Custom Key Bindings: I assigned Suspend to a hotkey. When I use it, the computer goes to suspend but after I restart it, I am greeted by a rather useless "Do you really want to suspend" dialog.
Severity: Harmless

Terminology: Whenever I try to autocomplete the path using tab and this fails Terminology occasionally becomes unresponsive for half a minute or so. If I resize Terminology during that time the background image does not scale, meaning T hangs totally.
This happens only occasionally, I have not yet found a way to reliably reproduce this problem.
Severity: Medium

Dard created this task.Apr 4 2015, 7:10 AM
Dard updated the task description. (Show Details)
Dard raised the priority of this task from to Incoming Queue.
Dard added a project: enlightenment-git.
Dard added a subscriber: Dard.
zmike edited this Maniphest Task.Apr 9 2015, 1:44 PM
zmike edited this Maniphest Task.
zmike edited this Maniphest Task.
zmike edited this Maniphest Task.

Thanks for your constructive and detailed feedback.

Regarding the personal application launcher, I just tested this and it seems to work as expected: the .desktop is saved to the local apps dir (eg. ~/.local/share/applications). Using the favorite apps dialog and adding it to favorites causes it to show up in the favorites menu as expected. This is not an ideal process, but it does appear to work.

EFM is not what one might call an "advanced" filemanager. As such, it has no capacity to display sizes of files in list view.

For suspending with the window present on resume, I would need to know exactly which suspend action you chose.

zmike edited this Maniphest Task.Apr 9 2015, 1:46 PM
Dard added a comment.EditedApr 11 2015, 3:28 AM

Okay, I just pulled and recompiled E. (I am no longer able to use the OpenGL renderer, I don't know why, but this is not a problem and an issue for another time)

Step-by-step:

  • Settings->Apps->Personal Application Launchers
  • Add
  • Name: Pillars of Eternity Application: pathTo/Pillars\ of\ Eternity/start.sh Icon: pathTo/PillarsOfEternity.png
  • Apply->Close

A new file is created: ~/.local/share/applications/Pillars_of_Eternity.desktop
(see attachment){F14102}

  • Run Everything: New App is visible here and can be launched (with icon)
  • Settings->Apps->Favourite Applications: New App is found here (without icon!)
  • Add: New app is listed in "Order" tab (with icon!)
  • Apply->Close

Pillars_of_Eternity.desktop is now listed in ~/.e/e/applications/menu/favorite.menu
(see attachment){F14103}

  • Favorite Applications: New app does not appear in menu
  • right-click Favorite Applications: New app does not appear in menu

As for the suspend problem: It seems to be my fault. I assigned "Suspend" and didn't notice there is a "Suspend now" option. This is the correct one, right?
(I don't know what "Suspend intelligently" is supposed to mean)

zmike added a comment.Apr 20 2015, 1:15 PM

The favorite apps menu should update as expected now; it previously would need an E restart.

Suspend now is indeed the action that you probably want for this behavior.

Dard added a comment.Apr 21 2015, 1:21 PM

The problem was never that I had to restart E for the changes to take effect. I always restarted E. The menu entry never showed up in Favourite Applications, even after restarting.

Anyway, I reinstalled E and tested again.
The problem persists. Since it seems you can't reproduce the problem at your system I wiped my .e and my .local directories and retried on a blank system.
The problem is still there. I cannot create custom applications launchers and add them to the Favourite Applications menu, just like I described above.

Besides that I seen now that the file selection dialog is now resizable. Good. Surprisingly, this is only the case in the one that is opened when I am about to choose the application to start. When I want to choose the icon, the file selection dialog still can't be resized.

abyomi0 added a subscriber: abyomi0.
stefan_schmidt triaged this task as Normal priority.Jul 24 2015, 2:45 AM
stefan_schmidt added a subscriber: stefan_schmidt.
billiob changed the visibility from "All Users" to "Public (No Login Required)".Dec 27 2015, 2:53 PM

i can't reproduce a single thing on your list above. :(

terminology works with both ibus and scim for jp input. i have it set up to do both jp and kr input and can switch.

my gtk fonts are nice - but then i installed a theme and set it up to my liking.

i have none of the hang issues you have with terminology and tab completion.

as for suspend - it may be that there are multiple things competing for that key. one that suspends immediately, the other that asks if u are sure. suspend now is the "just do it and don't ask". if e is suspending, it will fade out to black and suspend, and fade back in on resume. if its something else (systemd, init, some acpid thing) then you will see instant suspend. suspend "intelligently" is what suspend should be, but i did this to ceep compatibility with existing user configs. it will suspend *IF* no "external display is on". this is for laptops where you may set a lid close to suspend, but if you have an external screen plugged in, you dont want this - you want it to remain alive even with lid closed as you are using the external monitor.

your enlightenment responsive and blinking issues on start may be due to radeon + randr or something. i see no issues on nvidia or intel cards. e will configure randr on startup if you asked it to restore on startup. so the blinking may be a side-effect of the screen config being applied. it may be that your driver doesnt take to this very kindly and is slow in applying and takes some time. check your log output from e and grep for lines starting with "RRR" for e's randr subsystem logs to find what it is doing. if e is looping and applying the screen config all the time - then something odd is up, but it may explain the continual hangs for a few seconds and your blanking.

and as i said - everything else - i can't reproduce at all. :(

Dard added a comment.EditedDec 28 2015, 2:37 PM

I had almost forgotten about my bug reports.
I am sorry, I got distracted in the last couple of months.

Since you said you can't reproduce them, I am now going to try to reproduce them myself.
My Enlightement installation is about three weeks old. (I think)

File selection dialog:
Like I wrote before, the dialog is now resizable.

Keyboard Settings:
The apply button is clickable from the beginning. Everything all right.

File Manager:
The file properties now show up correctly.

Language Settings:
Changing the language setting is now possible.

Clock:
Still not custompizable enough. But this is not a bug but a feature request.

GTK-Fonts:
I really don't know if this would still be a problem.
I've tweaked the system several times in the meantime and can't remember what I did. My fonts are still a bit small but mostly okay now. I guess you can strike this from the bug list since I am not even sure if anything can be done about it if it is stll an issue.

Terminology: Japanese input problem
I still can't use ibus-anthy to enter japanese characters in terminology although I can in jedit, firefox and possibly others.
Strange.

Enlightenment: startup problems
I can't remember when it stopped, but now that you mention it, I can't remember when the problems happened the last time.
It seems the problems have gone away some time in the past. I probably should also mention that I also don't have other bugs like the different fonts on console anymore, which may mean the problems had to do with driver issues that have been fixed since.

Terminology: Autocomplete problem
Like with Enlightenment's startup problems: The problem went away some time in the past.

Custom Key Bindings: Suspend
Does not seem to be a problem anymore. A test I did succeeded.
The problem is that I don't remember to which key I assigned the action before. I've got the suspicion that I accidentally assigned "suspend" and "suspend now" to the same key.
Anyway, ignore!

Now for the (IMO) most important problem because it was a feature I really looked forward to when I switched to Enlightement:

Personal Application Launcher
I replayed the step-by-step instruction I have given and the problem is still the same. I can't add custom launchers to the Favorite Applications menu.
I also noticed that while my custom app is listed in the "Run Everyting" dialog, it does not show up in the "Applications" menu. They should be identical, shouldn't they?

Clock

The date display follows locale so if you customize it or choose the right locale (eg canada or uk or australia etc.) you'll modify the date display. there are other options for display - not everything on the planet, but a few.

Terminology + JP Input

That's ibus. I've tried UIM and SCIM too. fyi SCIM is the best supported by far. efl doesn't have endless input modules for every imaginable input method. We have ibus, scim, wayland and xim. is your efl compiled with ibus ecore_imf support? there should be a module in PREFIX/lib/ecore_imf/modules/ for ibus then.

Personal Application Launcher

I just added BLAH as personal app launcher (just dummy thing runs terminology) with the banana icon. it's there in the favorites menu - there in the dialogs where i added it. it's working for me perfectly. :/

raster closed this task as Resolved.Mar 11 2018, 1:27 AM

I can't reproduce any of these today at any rate except:

GTK-Fonts

and well - there are enough 3rd part tools there i think as there are enough other things to work on.

so i'm going to say this is resolved basically as everything is resolved except gtk fonts and that's more a wishlist rather than normal bug, and solved with editing your gtkrc files etc.