Page MenuHomePhabricator

[elementary] win_example multiple issues
Closed, ResolvedPublic

Description

Setup:

eflmasterheads/master-0-g17f1850
elementarymasterheads/master-0-gaecee4c

Steps to reproduce:

  1. Launch win_example
    • $ ./win_example
  2. There are multiple issues with win_example, the list is below:

Non-managed window:

  • Buttons don't work:
    • All except fullscreen, maximized, rotation, rotation_resize
  • Fullscreen gets stuck
  • Non-managed window has borders
  • Non-editable text can be edited

Managed Window:

  • Buttons do nothing:
    • activate
    • lower
    • rise
    • shaped
    • maximized
    • iconified
    • sticky
  • Rotation moves window to upper left corner
  • Fullscreen gets stuck on, can't unfullscreen

Extras:

None

brian.lovin added a project: Restricted Project.
brian.lovin added subscribers: brian.lovin, wayland-efl.
brian.lovin added a project: Restricted Project.Jul 31 2013, 1:43 PM
devilhorns triaged this task as Pending on user input priority.Aug 7 2013, 1:24 AM
devilhorns removed devilhorns as the assignee of this task.

99% of the problems on this report are because there is no ICCCM/NetWm equiv. implementation inside Weston (or any other wayland compositor/shell). These will eventually work when all of that has been hashed out on the wayland side. Reporting non-functional things like this due to missing functionality inside wayland/weston is not exactly helpful.....rather annoying actually.

raster added a subscriber: raster.
devilhorns removed devilhorns as the assignee of this task.Feb 26 2014, 5:02 AM

Yes, a lot of these don't work for X11 either. It's not a specific engine problem but rather a poorly coded example.

devilhorns renamed this task from [wayland] win_example multiple issues to [elementary] win_example multiple issues.Feb 26 2014, 5:02 AM
devilhorns removed a project: Restricted Project.
seoz claimed this task.Aug 22 2014, 10:35 AM
stefan_schmidt edited projects, added efl; removed Restricted Project.Jul 20 2016, 7:43 AM
zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 7:02 AM
bu5hm4n reassigned this task from seoz to segfaultxavi.Jun 11 2018, 9:07 AM
bu5hm4n edited projects, added efl: widgets; removed Restricted Project.
segfaultxavi raised the priority of this task from Pending on user input to Normal.Jun 12 2018, 7:14 AM

Although this ticket is rather old and most of the things it describes seem to be working now, this example does still have some issues, so it is worth taking another look.

segfaultxavi added a comment.EditedJul 2 2018, 7:40 AM

After taking a second look, almost everything seems to work as expected: All buttons work on the managed window, except fullscreen, and nothing works on the unmanaged window, except rotation.

This has been tested on a VM with X11 and Wayland. I can test again with real hw in a few days, but until then, maybe somebody else can take a look.

zmike changed the visibility from "All Users" to "Public (No Login Required)".Jan 15 2019, 9:54 AM
zmike added a subscriber: zmike.

I'm gonna say good enough.

Herald closed this task as Resolved. · View Herald TranscriptJan 15 2019, 10:47 AM

Ho Ho Ho! This issue was fixed by Santa!