Page MenuHomePhabricator

Terminology crashes when you open 2 tabs with htop
Closed, ResolvedPublic

Description

Hi,

Terminology crashes when you open 2 tabs, each of them running a program that produces output messages continously. An example is using htop or top, but it also happens with apt-get update.

Steps to reproduce:

  • Open terminology
  • Start top or htop or any command that produces a lot of output
  • Open a second tab and start in it top or htop

Additional information:

  • OS: Linux Debian Sid amd64
  • Using X Window

I attached the resulting Terminology.log although it does not contain too much information.

Regards,

Juan

jcomesana updated the task description. (Show Details)
jcomesana raised the priority of this task from to Incoming Queue.
jcomesana added a project: Terminology.
jcomesana added a subscriber: jcomesana.

I've tried to reproduced that issue but it works fine for me.
Which version of Terminology are you using?

One built from the latest source code from the git repo.

Could you get a backtrace?

This is what I get from running terminology with gdb:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffe9a43700 (LWP 7149)]
__memmove_avx_unaligned ()

at ../sysdeps/x86_64/multiarch/memcpy-avx-unaligned.S:266

266 ../sysdeps/x86_64/multiarch/memcpy-avx-unaligned.S: Non hai tal ficheiro ou directorio.

And the backtrace of the thread:

#0 __memmove_avx_unaligned () at ../sysdeps/x86_64/multiarch/memcpy-avx-unaligned.S:266
#1 0x00007ffff6c150cd in evas_common_draw_context_cutouts_del (rects=0x7fffe0000cd0, idx=0) at lib/evas/common/evas_draw_main.c:46
#2 0x00007ffff6c159fb in evas_common_draw_context_cutout_split (res=0x7fffe0000cd0, idx=0, split=0xa53cc0) at lib/evas/common/evas_draw_main.c:344
#3 0x00007ffff6c167a4 in evas_common_draw_context_apply_cutouts (dc=0xb13220, reuse=0x7fffe0000cd0) at lib/evas/common/evas_draw_main.c:609
#4 0x00007ffff6c17ec7 in evas_common_font_draw_cb (dst=0xad73c0, dc=0xb13220, x=-257, y=88, glyphs=0xb028b0, cb=0x7ffff6c17324 <evas_common_font_rgba_draw>) at lib/evas/common/evas_font_draw.c:406
#5 0x00007ffff6c18026 in evas_common_font_draw (dst=0xad73c0, dc=0xb13220, x=-257, y=88, glyphs=0xb028b0) at lib/evas/common/evas_font_draw.c:425
#6 0x00007ffff6c784e5 in _draw_thread_multi_font_draw (data=0xac07a0) at modules/evas/engines/software_generic/evas_engine.c:2472
#7 0x00007ffff6c3e875 in evas_thread_worker_func (data=0x0, thread=140737113241344) at lib/evas/common/evas_thread_render.c:110
#8 0x00007ffff73f47c9 in _eina_internal_call (context=0x6a6dd0) at lib/eina/eina_thread.c:125
#9 0x00007ffff7196284 in start_thread (arg=0x7fffe9a43700) at pthread_create.c:333
#10 0x00007ffff3e3074d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

I've tried to reproduced that issue but it works fine for me.
Which version of Terminology are you using?

Same here, couldn't reproduce it today's git checkout!

jcomesana added a comment.EditedJan 17 2016, 3:46 AM

With the latest source from git can still reproduce the bug.

I made some more tests and it seems to be related to the theme selected in terminology. With default and solarized themes, the crash comes fast. With the black theme, it happens much later.

More information, it seems that it happens only when the miniview is visible.

The miniview feature is very buggy ☹.

I am unable to reproduce this on 0.9.1 with miniview, default theme and top -d 0.01 in 3 tabs. Maybe this was fixed?

billiob closed this task as Resolved.May 14 2016, 3:14 AM
billiob claimed this task.

Let's close it.