Page MenuHomePhabricator

Terminology crash
Closed, ResolvedPublic

Description

Terminology has crashed twice with similar stacktraces:

crash 1
crash 2

I'm using terminology 0.9.1, from the archlinux repositories.

RX14 created this task.Dec 26 2015, 9:52 AM
RX14 updated the task description. (Show Details)
RX14 raised the priority of this task from to Incoming Queue.
RX14 added a project: Terminology.
RX14 added a subscriber: RX14.

This looks like an issue in EFL.

billiob added subscribers: raster, cedric.

unfortunately - that there says "something corrupted memory, but we don't know where or what". the corruption happened some time prior to this backtrace and crash - when/where - no idea. this is where you need valgrind to catch it. what were you doing when this happened? what had you done prior to it and over the lifetime of the terminology process? i.e. - how to reproduce it?

RX14 added a comment.Jan 1 2016, 3:13 PM

Sorry for the late reply, I've been busy.

I cannot find a pattern to the crashes, they seem to happen when I have a lot of terminals open, all continuously updating.

I'm running terminology under valgrind now, but it hasn't crashed yet. I'll stick at it and report valgrind output of any crashes.

stefan_schmidt triaged this task as Normal priority.Jan 7 2016, 7:13 AM
stefan_schmidt added a subscriber: stefan_schmidt.
RX14 added a comment.Jan 7 2016, 11:43 AM

I haven't managed to make it crash under valgrind, whether this is because valgrind somehow stops the bug, or because I'm unlucky, I don't know.

The crash seems to only occur when there are many terminals updating at once.

do you use the single process mode? (multiple instances, one process)? or multiple processes?

RX14 added a comment.Jan 13 2016, 2:04 PM

I use single process mode.

billiob closed this task as Resolved.May 14 2016, 3:26 AM
billiob claimed this task.

If we can't reproduce it, let's close it.