Page MenuHomePhabricator

EConnMan Seg Faults in E20
Closed, InvalidPublic

Description

EConnMan 1.1-3 running in Manjaro Linux E0.20.1 in X session with ConnMan 1.30-1 segfaults.

To reproduce:

  • Click connection icon on a shelf then "Configuration" in the popup --> segfault
  • Right click connection icon on a shelf then "Settings" for connection manager --> segfault.
  • Trying to launch from a menu (with or without agent) --> segfault
aguador created this task.Dec 27 2015, 10:19 AM
aguador updated the task description. (Show Details)
aguador raised the priority of this task from to Incoming Queue.
aguador added a project: Restricted Project.
aguador added a subscriber: aguador.
aguador updated the task description. (Show Details)Dec 27 2015, 11:03 AM
aguador updated the task description. (Show Details)Dec 27 2015, 11:01 PM
kuuko triaged this task as Pending on user input priority.Feb 15 2016, 4:29 AM
kuuko added a subscriber: kuuko.

If this is still an issue, please provide a backtrace. You can get a backtrace with this command:

gdb --args python3.4 /usr/bin/econnman-bin

provided you have gdb installed and the libraries have their debugging symbols installed.

(In the command above change the python version and econnman path to apply to your system.)

aguador added a comment.EditedFeb 15 2016, 1:12 PM

From the last line of the output it looks as if I am missing debugging symbols. I am swamped at the moment, so I can likely not get to adding symbols until the weekend. For what it's worth, here is the output so far. Let me know if, by chance, it helps:

Starting program: /usr/bin/python3.5 /usr/bin/econnman-bin
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Traceback (most recent call last):
File "/usr/share/gdb/auto-load/usr/lib/libeo.so.1.16.0-gdb.py", line 7, in <module>
    import eo_gdb
ImportError: No module named 'eo_gdb' 
[New Thread 0xb6623b40 (LWP 1508)]
[New Thread 0xb4428b40 (LWP 1509)]

Program received signal SIGILL, Illegal instruction.
0xb71465d8 in ?? () from /usr/lib/libevas.so.1

[NOTE: libevas.so.1 = libevas.so.1.16]

kuuko added a project: efl.Feb 16 2016, 8:42 PM
kuuko added subscribers: raster, cedric.

SIGILL could indicate a bad optimization or code path in Evas. CC @raster and @cedric.

Backtrace with full symbols is likely to be required to solve this. Also, probably useful information would be about your hardware and the operating system you're using.

ok - that sigill is probably fine. it's evas detecting your cpu model by trying to execute instructions that mabe invalid, trapping them with its own SIGILL handler and thus blacklisting that optimized asm path if that instruction doesnt work. so just "continue" there. you must have an old-ish cpu to be hitting these sigills tho.

aguador added a comment.EditedFeb 17 2016, 2:13 AM

Thanks. Sorry for the delay in getting a backtrace, but I'm just catching time between work these days.

As noted, this occurs with E20.1 in Manjaro Linux. My main machines are two aged (i.e., past aging) 32-bit machines: a Pentium M and an Atom N270 (I think). However, this also happens with my second gen Core i5 laptop (confirmed today). I also recall someone running Manjaro on 64-bit equipment reporting problems.

I will send the bug link to a colleague and, I promise, compile Econnman with symbols this weekend.

what i was saying is the sigill is not fatal - the one you have above. thats just evas figuring out what machine its on. "continue" in gdb and find the actual issue elsewhere. it5 may have several sigills there at startup as it tries sse3, sse, mmx, mmx2 etc. depending how old the cpu is.

OK, I've built and installed econnman with -O0 and -g flags . . . and it now returns "No stack."

Admittedly I am new at building and debugging, but I am reasonably sure everything built and installed correctly. I uninstalled the version from the respositories, downloaded the tarball from the E site and built with the Arch pkgbuild modified with only the addition of the -O0, -fbuiltin and -g flags.

kuuko added a comment.Feb 19 2016, 8:42 AM

Do you see that message in the debugger or when running econnman at terminal without debugger?

econnman-bin is a python script so when building it the compile flags go unused. The flags will be useful however when building packages efl, elementary and python-efl, which are C libraries. The backtrace will be meaningful when those packages are built with debugging flags.

My apologies for the long delay. I had a couple of compile errors I haven't had time to follow up on . However, another Manjaro user seems to have solved the issue. There has been an out-of-date python-efl package (1.15) in the repositories. At first blush all seems to be well after installing 1.17. However, if we could leave the report open just a wee bit longer I will turn back to doing a trace just in case.

kuuko closed this task as Invalid.May 3 2016, 1:30 AM