Page MenuHomePhabricator

E doesn't come back when changing TTY.
Closed, ResolvedPublic

Description

To reproduce:

  1. Ctrl+Alt+F2
  2. Ctrl_Alt+F1

It still runs but doesnt render. You have to kill it.

ApB created this task.Jan 8 2016, 9:53 AM
ApB updated the task description. (Show Details)
ApB raised the priority of this task from to Incoming Queue.
ApB added projects: enlightenment-git, Restricted Project.
ApB added a subscriber: ApB.

Cannot reproduce here. switches just fine.

maxule added a subscriber: maxule.Jan 10 2016, 1:29 PM

When E is started by “enlightenment_start”, it occurs (and UHD resolution switching is having errno-no-memory). Lots of EINA_SAFETY-crashes.

When starting from lxdm, all (TTY and mode)-switching works fine, EINA_SAFETY-crashes disappear. I'll continue testing on this.

ApB added a comment.Jan 16 2016, 4:03 AM

This happens -as with a lot of other bugs- when you have async rendering. If you export ECORE_EVAS_FORCE_SYNC_RENDER=1 it gets back to it just fine. However it has a glitch. If you get back it enables the frame rate in the advanced composite settings.

The frame rate showing should be fixed in git now, however I still cannot reproduce this issue with async rendering enabled.

ApB added a comment.Jan 25 2016, 10:53 AM

Yeah i tested the frame rate thing. Derek commented on T2862 and mentioned that there is a problem with async on wayland and that he pushed some fixes upstream. But we'll have to wait for the 1.10 release.

ApB closed this task as Resolved.Mar 11 2016, 12:33 PM

Fixed.