Page MenuHomePhabricator

Crash when closing Xwayland apps.
Closed, ResolvedPublic

Description

         PID: 21456 (enlightenment)
         UID: 1000 (toliz)
         GID: 1000 (toliz)
      Signal: 11 (SEGV)
   Timestamp: Sat 2016-01-16 14:10:37 EET (4min 52s ago)
Command Line: /usr/bin/enlightenment
  Executable: /usr/bin/enlightenment

Control Group: /user.slice/user-1000.slice/session-c1.scope

      Unit: session-c1.scope
     Slice: user-1000.slice
   Session: c1
 Owner UID: 1000 (toliz)
   Boot ID: 6b47555ee7fa48268ee794d34c5cfbc2
Machine ID: 77c42d073644466287ad3d7a519e810c
  Hostname: testland
  Coredump: /var/lib/systemd/coredump/core.enlightenment.1000.6b47555ee7fa48268ee794d34c5cfbc2.21456.1452946237000000.lz4
   Message: Process 21456 (enlightenment) of user 1000 dumped core.

            Stack trace of thread 21456:
            #0  0x00000000080a5adf _e_comp_object_setup (enlightenment)
            #1  0x00000000b71a2ec0 _hide (libevas.so.1)
            #2  0x00000000b71a2c0c _evas_object_efl_gfx_base_visible_set (libevas.so.1)
            #3  0x00000000b6440df4 efl_gfx_visible_set (libefl.so.1)
            #4  0x00000000b71a2b5c evas_object_hide (libevas.so.1)
            #5  0x00000000b71a11a3 _evas_object_eo_base_destructor (libevas.so.1)
            #6  0x00000000b6432801 eo_destructor (libeo.so.1)
            #7  0x00000000b642aac0 _eo_del_internal (libeo.so.1)
            #8  0x00000000b642adda _eo_unref (libeo.so.1)
            #9  0x00000000b642c285 _eo_do_end (libeo.so.1)
            #10 0x00000000b642e6b5 eo_del (libeo.so.1)
            #11 0x00000000b71a114a evas_object_del (libevas.so.1)
            #12 0x000000000808cdda _e_client_free (enlightenment)
            #13 0x000000000814d5d6 e_object_free (enlightenment)
            #14 0x000000000814d794 e_object_unref (enlightenment)
            #15 0x000000000808c2ed _e_client_event_simple_free (enlightenment)
            #16 0x00000000b6e3de78 _ecore_call_end_cb (libecore.so.1)
            #17 0x00000000b6e3e90a _ecore_event_del (libecore.so.1)
            #18 0x00000000b6e3e9af _ecore_event_purge_deleted (libecore.so.1)
            #19 0x00000000b6e3ef73 _ecore_event_call (libecore.so.1)
            #20 0x00000000b6e490fb _ecore_main_loop_iterate_internal (libecore.so.1)
            #21 0x00000000b6e4737c ecore_main_loop_begin (libecore.so.1)
            #22 0x0000000008078264 main (enlightenment)
            #23 0x00000000b6b3a497 __libc_start_main (libc.so.6)
            #24 0x0000000008072b11 _start (enlightenment)

GNU gdb (GDB) 7.10.1
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
http://www.gnu.org/software/gdb/bugs/.
Find the GDB manual and other documentation resources online at:
http://www.gnu.org/software/gdb/documentation/.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/enlightenment...Reading symbols from /usr/lib/debug/usr/bin/enlightenment.debug...done.
done.
[New LWP 21456]
[New LWP 21457]
[New LWP 21491]
[New LWP 21492]
[New LWP 21462]

warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/enlightenment'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x080a5adf in _e_comp_object_setup (cw=0x801ad370) at src/bin/e_comp_object.c:825
825 evas_object_event_callback_add(cw->smart_obj, EVAS_CALLBACK_MOUSE_IN, _e_comp_object_cb_mouse_in, cw);
[Current thread is 1 (Thread 0xb56b87c0 (LWP 21456))]
(gdb) bt
#0 0x080a5adf in _e_comp_object_setup (cw=0x801ad370) at src/bin/e_comp_object.c:825
#1 0xb71a2ec0 in _hide (eo_obj=0x801ad370, obj=0xa657c60) at lib/evas/canvas/evas_object_main.c:1300
#2 0xb71a2c0c in _evas_object_efl_gfx_base_visible_set (eo_obj=0x801ad370, obj=0xa657c60, visible=0 '\000') at lib/evas/canvas/evas_object_main.c:1239
#3 0xb6440df4 in efl_gfx_visible_set (v=0 '\000') at ../src/lib/efl/interfaces/efl_gfx_base.eo.c:9
#4 0xb71a2b5c in evas_object_hide (eo_obj=0x801ad370) at lib/evas/canvas/evas_object_main.c:1221
#5 0xb71a11a3 in _evas_object_eo_base_destructor (eo_obj=0x801ad370, obj=0xa657c60) at lib/evas/canvas/evas_object_main.c:678
#6 0xb6432801 in eo_destructor () at lib/eo/eo_base.eo.c:34
#7 0xb642aac0 in _eo_del_internal (file=0xb6433dc3 "lib/eo/eo_private.h", line=301, obj=0xa657c28) at lib/eo/eo_private.h:221
#8 0xb642adda in _eo_unref (obj=0xa657c28) at lib/eo/eo_private.h:301
#9 0xb642c285 in _eo_do_end (eo_stack=0xa0256e0) at lib/eo/eo.c:509
#10 0xb642e6b5 in eo_del (obj=0x801ad370) at lib/eo/eo.c:1557
#11 0xb71a114a in evas_object_del (eo_obj=0x801ad370) at lib/evas/canvas/evas_object_main.c:665
#12 0x0808cdda in _e_client_free (ec=0xa657830) at src/bin/e_client.c:558
#13 0x0814d5d6 in e_object_free (obj=0xa657830) at src/bin/e_object.c:119
#14 0x0814d794 in e_object_unref (obj=0xa657830) at src/bin/e_object.c:152
#15 0x0808c2ed in _e_client_event_simple_free (d=0x0, ev=0xa84c670) at src/bin/e_client.c:336
#16 0xb6e3de78 in _ecore_call_end_cb (func=0x808c2d9 <_e_client_event_simple_free>, user_data=0x0, func_data=0xa84c670) at lib/ecore/ecore_private.h:361
#17 0xb6e3e90a in _ecore_event_del (event=0xa82d370) at lib/ecore/ecore_events.c:396
#18 0xb6e3e9af in _ecore_event_purge_deleted () at lib/ecore/ecore_events.c:414
#19 0xb6e3ef73 in _ecore_event_call () at lib/ecore/ecore_events.c:600
#20 0xb6e490fb in _ecore_main_loop_iterate_internal (once_only=0) at lib/ecore/ecore_main.c:2386
#21 0xb6e4737c in ecore_main_loop_begin () at lib/ecore/ecore_main.c:1297
#22 0x08078264 in main (argc=1, argv=0xbf9354a4) at src/bin/e_main.c:1062
(gdb)

ApB created this task.Jan 16 2016, 4:16 AM
ApB updated the task description. (Show Details)
ApB raised the priority of this task from to Incoming Queue.
ApB added projects: Restricted Project, enlightenment-git.
ApB added a subscriber: ApB.
zmike triaged this task as Pending on user input priority.Jan 18 2016, 12:11 PM

Opened xterm, closed xterm. No crash.

Also your backtrace makes zero sense. _e_comp_object_setup() is only called during show, yet it's called here during hide. Adding some internals experts...

Which version of E? Which distro? Which versions of Wayland...?

As zmike said, the calls sequence doesn't make sense.

ApB added a comment.Jan 19 2016, 5:44 AM

Arch with everything standard (whatever comes from the repos) and E from git.

The thing is after building today i can't reproduce it anymore. :/

ApB closed this task as Resolved.Aug 26 2016, 1:41 PM

Magic fix.