Page MenuHomePhabricator

Terminology's default font configuration is not quite reasonable
Closed, InvalidPublic

Description

Terminology seems to have too small of a default font size (0.9.1 is the version I am running), and for reference, I've taken a screenshot of this cute little terminal emulator with Konsole for your comparison.

MingcongBai updated the task description. (Show Details)
MingcongBai raised the priority of this task from to Normal.
MingcongBai added a project: Terminology.
MingcongBai added a subscriber: MingcongBai.

You should probably change your scaling factor when running elementary_config.

billiob lowered the priority of this task from Normal to Pending on user input.Feb 2 2016, 2:45 PM

You should probably change your scaling factor when running elementary_config.

While that works, don't you think it is quite unreasonable for a user to "run into" such an issue? Accessibility?

MingcongBai raised the priority of this task from Pending on user input to Normal.Feb 2 2016, 5:02 PM
billiob added a project: Restricted Project.Mar 6 2016, 2:44 AM

@raster, @cedric , @tasn
Should the scale-factor ui be shown on first launch of any elementary app if it never got configured?

bu5hm4n added a subscriber: bu5hm4n.Mar 6 2016, 6:30 AM

@billiob thats quite a good idea.

raster added a comment.Mar 6 2016, 3:24 PM

how would you know it has never been configured? i can come up with other cases where a default out of the box gtk or qt config would be stupid too and need manual configuring. e.g - your tv. if you go by dpi you will effectively have a ui that's unreadable from your couch.

tasn added a comment.Mar 7 2016, 5:02 AM

@raster, I think we need to optimise for the default case. I know you like having nexus there by default, but maybe we should use a bigger font? Or a bigger version of nexus? You use inhumanly small font sizes on your desktop, you are definitely not the yardstick...

raster added a comment.Mar 7 2016, 4:38 PM

look closely @tasn . that's not nexus by default. it's 10pt monospace ttf (either dejavu sans mono, liberation mono, droid sans mono or bistream vera sans mono).

the problem is SCALE FACTOR isn't "magically" being set to 2.0 because of "hi dpi" in elm config. this is intended to be manually configured. we do NOT go use dpi to scale and my example was where dpi scaling is also broken.

raster reopened this task as Open.Mar 7 2016, 4:45 PM

no. changing to 14 is not solution. what do you do when someone has an 8k screen? what about 4k on a 6" phone? seriously. this is a poor way of dealing with this. the solution is not in going and messing with terminology defaults. don't make me file another bug:

terminology default window doesn't fit on my VGA 640x480 screen. it goes off screen because default font is so huge. (at 14pt terminology default 80x24 window is 722x410 thus won't fit on VGA).

tasn added a comment.Mar 8 2016, 7:18 AM

@raster, I didn't even look at the screenie, just assumed that was the case. :)

tasn reopened this task as Open.Mar 8 2016, 7:19 AM

I guess you also probably wanted to reopen this.

raster added a comment.Mar 8 2016, 5:33 PM

bah shit - my revert closed. yes - i wanted it open as jst fiddling default font size is not a solution. so here are 2 ways to look at it:

  1. to make gtk apps look nice in e we had to implement a settings daemon to be able to tell them what font etc. to use. why do we have to do this work for gtk/gnome but everyone else gets to ignore efl and not implement any DE support to generate the appropriate elm config?

or

  1. you want elm to somehow have something that will use dpi to auto-set-scale. this is nothing terminology should be doing. maybe elm, should have a wizard setup app like e has built in and it is launched first time any elm app is launched and no user config exists (launched by elm itself whilst loading config)?

either way the solution is not in terminology and certainly not just arbitrarily changing font sizes.

the difference is that gtk generally chooses font sizes by points and thus they get affected by dpi. in efl we don't care about dpi and just set pixel sizes and EXPECT a scale factor config to deal with the "that's too small" or "that's too big" issue. dpi is not a solution as above - tv for example. even if we scaled on a phone based on dpi - we'd be far far too big because phones are normally held at 1/3rd the distance from a user than a desktop screen might be. thus explicit scale factor to deal with the COMBO of view distance PLUS dpi. it's part of efl's philosophy.

stefan_schmidt edited projects, added efl; removed Restricted Project.Jul 20 2016, 7:42 AM
raster closed this task as Invalid.Jul 26 2016, 1:04 AM

as per my last comment. set up a config with the right scale factor for your screen then it'll be fine. as with needing an xsettings for gtk. etc.