Page MenuHomePhabricator

tasks popup
Closed, InvalidPublic

Description

  1. Pres: Alt+Tab
  2. Release Tab
  3. Use arrow keys

Result

  • Window selection is random
  • While selecting windows with arrows, the task popup menu item is not hilighted
kiuma72 created this task.Feb 7 2016, 9:43 AM
kiuma72 updated the task description. (Show Details)
kiuma72 raised the priority of this task from to Incoming Queue.
kiuma72 added a project: enlightenment-git.
kiuma72 added a subscriber: kiuma72.
kiuma72 reopened this task as Open.Feb 27 2016, 5:41 AM

hilight now works, but arrow keys still don't

zmike closed this task as Resolved.Feb 27 2016, 8:04 AM

Arrow keys are directional. They have no relation to winlist item ordering.

kiuma72 reopened this task as Open.Feb 27 2016, 8:30 AM

maybe I wasn't clear in the issue
in a winlist of 10 windows using directionals it can't be that selected windows are just 1 9 4 in one direction and 7 and 1 in the other.
Imho this is a regression because once it worked as expected
(I'm not speaking of creation order, just winlist order as they appear)
I think that directionals should behave like mouse wheel on winlist as it worked once.

kiuma72 reopened this task as Open.Mar 14 2016, 7:04 AM

Directional left-right are now ok and respect the taskbar sorting.

but using up and down doesn't work, should produce the same effect of mouse wheel and actually pressing up/down corrupts the popup

zmike reassigned this task from zmike to raster.Mar 30 2016, 1:11 PM

not here. up/down and left/right navigate windows VISUALLY - eg you have 4 windows stacked vertically like:

win1
win2
win3
win4

then up/down will select them in visual vertical fashion. so down == win1 -> win2 -> win3 -> win4, then up 3 times will be win4 -> win3 -> win2 -> win1

i'm diung it right here. it works. maybe it doesnt work as you THINK it does (follows the vertical order in the LIST) but it works as it is designed (arrows do visual layout order) and tab/shift tab are there still for linear (list) order.

zmike closed this task as Invalid.May 9 2016, 10:56 AM