Page MenuHomePhabricator

Ecore_con ares compilation fails (on Windows)
Closed, ResolvedPublic

Description

On Windows, ecore_con uses the c-ares library. But now, ecore_con_ares.c does not compile. Here is some errors (there are a lot of them...) :

lib/ecore_con/ecore_con_ares.c:292:4: error: unknown type name 'Ecore_Con_Server_Data'
    Ecore_Con_Server_Data *svr = eo_data_scope_get(obj, ECORE_CON_SERVER_CLASS);
    ^
lib/ecore_con/ecore_con_ares.c:292:56: error: 'ECORE_CON_SERVER_CLASS' undeclared (first use in this function)
    Ecore_Con_Server_Data *svr = eo_data_scope_get(obj, ECORE_CON_SERVER_CLASS);
                                                        ^
lib/ecore_con/ecore_con_ares.c:292:56: note: each undeclared identifier is reported only once for each function it appears in
In file included from ../src/lib/evil/Evil.h:172:0,
                 from ../src/lib/eina/Eina.h:207,
                 from ../src/lib/ecore/Ecore.h:304,
                 from lib/ecore_con/ecore_con_ares.c:25:
lib/ecore_con/ecore_con_ares.c:314:30: error: request for member 'ecs' in something not a structure or union
    if (inet_pton(AF_INET, svr->ecs ? svr->ecs->ip : svr->name, &cares->addr.v4) == 1)
                              ^
../src/lib/evil/evil_macro_wrapper.h:16:43: note: in definition of macro 'inet_pton'
 #define inet_pton(x,y,z) evil_inet_pton(x,y,z)
                                           ^
lib/ecore_con/ecore_con_ares.c:314:41: error: request for member 'ecs' in something not a structure or union
    if (inet_pton(AF_INET, svr->ecs ? svr->ecs->ip : svr->name, &cares->addr.v4) == 1)
                                         ^
../src/lib/evil/evil_macro_wrapper.h:16:43: note: in definition of macro 'inet_pton'
 #define inet_pton(x,y,z) evil_inet_pton(x,y,z)
                                           ^
lib/ecore_con/ecore_con_ares.c:314:56: error: request for member 'name' in something not a structure or union
    if (inet_pton(AF_INET, svr->ecs ? svr->ecs->ip : svr->name, &cares->addr.v4) == 1)
                                                        ^
../src/lib/evil/evil_macro_wrapper.h:16:43: note: in definition of macro 'inet_pton'
 #define inet_pton(x,y,z) evil_inet_pton(x,y,z)
                                           ^
lib/ecore_con/ecore_con_ares.c:325:36: error: request for member 'ecs' in something not a structure or union
    else if (inet_pton(AF_INET6, svr->ecs ? svr->ecs->ip : svr->name, &cares->addr.v6) == 1)
                                    ^
../src/lib/evil/evil_macro_wrapper.h:16:43: note: in definition of macro 'inet_pton'
 #define inet_pton(x,y,z) evil_inet_pton(x,y,z)
                                           ^
lib/ecore_con/ecore_con_ares.c:325:47: error: request for member 'ecs' in something not a structure or union
    else if (inet_pton(AF_INET6, svr->ecs ? svr->ecs->ip : svr->name, &cares->addr.v6) == 1)
                                               ^
../src/lib/evil/evil_macro_wrapper.h:16:43: note: in definition of macro 'inet_pton'
 #define inet_pton(x,y,z) evil_inet_pton(x,y,z)
                                           ^
lib/ecore_con/ecore_con_local_win32.c: In function '_ecore_con_local_win32_server_read_client_handler':
lib/ecore_con/ecore_con_local_win32.c:39:57: error: 'EFL_NETWORK_CLIENT_CLAS' undeclared (first use in this function)
    Efl_Network_Client_Data *cl = eo_data_scope_get(obj, EFL_NETWORK_CLIENT_CLAS);
                                                         ^
lib/ecore_con/ecore_con_ares.c:325:62: error: request for member 'name' in something not a structure or union
    else if (inet_pton(AF_INET6, svr->ecs ? svr->ecs->ip : svr->name, &cares->addr.v6) == 1)
                                                              ^

maybe the problem is here since the use of Efl.Network.Client

I have no idea on how to fix this, but it's a big problem imho

vtorri created this task.Feb 16 2016, 11:34 AM

note also that i have eolian messages like this one :

eolian:ecore_con_eet_base.eo:12:19: undefined type Ecore_Con_Server

(and a lot more, for evas, eldbus)

jpeg added a subscriber: jpeg.Feb 16 2016, 8:27 PM
jpeg added a comment.Feb 18 2016, 10:57 PM

@vtorri please close if the build is fixed

vtorri closed this task as Resolved.Feb 18 2016, 11:19 PM

it's compiling,