Page MenuHomePhabricator

Scaling Dialog
Closed, ResolvedPublic

Description

So I took a look at the Scaling window today

Name : efl-git
Version : 1.17.99.33226.2444e12-1
Build Date : Sat 13 Feb 2016 02:55:40 PM EST
Install Date : Sat 13 Feb 2016 03:37:24 PM EST

Name : enlightenment-git
Version : 0.20.99.21035.e8b8fe8-1
Build Date : Sat 13 Feb 2016 03:12:55 PM EST
Install Date : Sat 13 Feb 2016 03:37:36 PM EST

Name : elementary-git
Version : 1.17.99.12585.g8150643-1
Build Date : Sat 13 Feb 2016 03:54:13 PM EST
Install Date : Sat 13 Feb 2016 03:54:42 PM EST

abyomi0 created this task.Feb 16 2016, 7:43 PM

I can't think of any changes in Enlightenment which could have caused this. I suspect some recent efl/elementary change.

zmike added a comment.Feb 17 2016, 2:07 PM

Upon further consideration, this is almost definitely caused by the recent animator changes that @cedric made--the same ones which broke cursors--since the issue in question is that a nested buffer canvas is failing to render.

tasn added a comment.Feb 18 2016, 7:03 AM

I'm way more comfortable with blaming @cedric than blaming me.

@zmike, are you able to reproduce it? If so, could you just revert @cedric's change locally and see if that solves it?

tasn added a comment.Feb 19 2016, 12:55 PM

I'm not sure what I'm seeing, but per my message to the ML, I found rELM79b6edd1a6ad763258337b7aac5bd7799411bb44 to be buggy and screw up my terminology. Maybe it's related?

In T3195#44717, @tasn wrote:

I'm not sure what I'm seeing, but per my message to the ML, I found rELM79b6edd1a6ad763258337b7aac5bd7799411bb44 to be buggy and screw up my terminology. Maybe it's related?

What are you experiencing with terminology?

zmike raised the priority of this task from Normal to High.Feb 19 2016, 2:08 PM

I can reproduce it, as can anyone who is using any buffer canvas which should render more than the first frame.

Not possible to revert since it's a large patch series. Should probably be a high priority issue.

@zmike I am surprised it is related at all to animator as the issue was fixed for the e pointer which is using an animator on a custom evas buffer canvas. So not to sure of the issue here. Could you point to me to the code that create that buffer ?

zmike added a comment.Feb 21 2016, 5:26 PM
In T3195#44721, @cedric wrote:

@zmike I am surprised it is related at all to animator as the issue was fixed for the e pointer which is using an animator on a custom evas buffer canvas. So not to sure of the issue here. Could you point to me to the code that create that buffer ?

I imagine it's the same issue in a different place/implementation: all code using ecore_evas_object_image_new to create a buffer canvas now fails to render anything past the first frame, and this began around the time that your animator change went in.

Yes.

tasn added a comment.Feb 22 2016, 5:46 PM

Terminology issue is now fixed.

zmike closed this task as Resolved.Dec 12 2016, 9:16 AM

This is resolved now without any changes in Enlightenment, so I guess it was an EFL regression.