Page MenuHomePhabricator

[JENKINS] dbus-daemon issue on the slaves
Closed, ResolvedPublic

Description

There is tons on dbus-daemon process running on the slaves. Do we have any chances to purge such process after the tests ?

jenkins+   506  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   525  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   540  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   552  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   564  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   577  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   642  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   668  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   691  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   705  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   719  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   730  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   744  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   756  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   767  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   779  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   790  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   802  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   813  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   824  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   835  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   847  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   859  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   870  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   881  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   892  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   904  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   916  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   927  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   938  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   949  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   962  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   975  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   986  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+   997  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1010  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1025  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1036  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1047  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1059  0.0  0.0  19652   228 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1071  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1082  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1095  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1106  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1118  0.0  0.0  19652   232 ?        Ss   Feb04   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+  1203  0.0  0.0  31320   308 ?        S    Feb04   0:00 dbus-launch --autolaunch 6ac23ccc246e46e2c8c07e9451276fdd --binary-syntax --close-stderr
jenkins+  1204  0.0  0.0  19656   296 ?        Ss   Feb04   0:09 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
beber created this task.Feb 21 2016, 5:58 AM
beber renamed this task from dbus-daemon issue on the slaves to [JENKINS] dbus-daemon issue on the slaves.
beber added a subscriber: stefan_schmidt.

I see less dbus-daemon process now but there is still:

jenkins+ 25039  0.0  0.0  19632   232 ?        Ss   May17   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+ 25249  0.0  0.0  19632   228 ?        Ss   May17   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+ 25306  0.0  0.0  19632   228 ?        Ss   May17   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+ 25563  0.0  0.0  19632   228 ?        Ss   May17   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+ 25801  0.0  0.0  19632   228 ?        Ss   May17   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+ 25841  0.0  0.0  19632   232 ?        Ss   May17   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
jenkins+ 27629  0.0  0.0  19636  1532 ?        Ss   May17   0:06 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
beber added a comment.Sep 12 2016, 4:18 PM

I confirm that the issue is still there.

Hi Guys I am looking at triaging issues if there has been no activity on them. Last response was september 13 2016 is this still an active issue?

beber closed this task as Resolved.Jul 30 2018, 1:00 PM

This issue is now fixed