Page MenuHomePhabricator

Excesive focus on gtk apps.
Closed, DuplicatePublic

Description

Not sure if this is a bug or the way wayland works but it doesn't happen on X.

Open transmission and click on the menu (file edit etc)
Every time you move to another (file to edit) the window and the submenu get focused and unfocused (+ the blue frame doesn't fit to the window geometry -is bigger by a few pixels)

ApB created this task.Apr 8 2016, 4:23 AM
ApB reopened this task as Open.Apr 23 2016, 2:19 AM

Not quite fixed. Still as you move between the menus the main window gets focus and blinks (blue square around) making it somehow annoying.

But as a bonus you introduced the thing below. Happens as you move between the menus.

coredumpctl gdb

         PID: 8825 (enlightenment)
         UID: 1000 (toliz)
         GID: 1000 (toliz)
      Signal: 11 (SEGV)
   Timestamp: Sat 2016-04-23 12:15:40 EEST (45s ago)
Command Line: /usr/bin/enlightenment
  Executable: /usr/bin/enlightenment

Control Group: /

     Slice: -.slice
   Boot ID: f7ccb416b5c047578da2d3520fe8298a
Machine ID: 77c42d073644466287ad3d7a519e810c
  Hostname: testland
  Coredump: /var/lib/systemd/coredump/core.enlightenment.1000.f7ccb416b5c047578da2d3520fe8298a.8825.1461402940000000000000.lz4
   Message: Process 8825 (enlightenment) of user 1000 dumped core.

            Stack trace of thread 8826:
            #0  0x00000000b7254cf6 evas_common_scale_rgba_sample_draw (libevas.so.1)
            #1  0x00000000b7294fa1 _draw_thread_image_draw (libevas.so.1)
            #2  0x00000000b72624fc evas_thread_worker_func (libevas.so.1)
            #3  0x00000000b73da5c3 _eina_internal_call (libeina.so.1)
            #4  0x00000000b6e92291 start_thread (libpthread.so.0)
            #5  0x00000000b6c26d7e __clone (libc.so.6)

            Stack trace of thread 8828:
            #0  0x00000000b7794d8d __kernel_vsyscall (linux-gate.so.1)
            #1  0x00000000b6c1f6d5 __select (libc.so.6)
            #2  0x00000000b70bceb4 _timer_tick_core (libecore.so.1)
            #3  0x00000000b70ce81c _ecore_direct_worker (libecore.so.1)
            #4  0x00000000b73da5c3 _eina_internal_call (libeina.so.1)
            #5  0x00000000b6e92291 start_thread (libpthread.so.0)
            #6  0x00000000b6c26d7e __clone (libc.so.6)

            Stack trace of thread 8825:
            #0  0x00000000b7794d8d __kernel_vsyscall (linux-gate.so.1)
            #1  0x00000000b6e9b09f read (libpthread.so.0)
            #2  0x00000000b71b9f82 _evas_async_events_process_single (libevas.so.1)
            #3  0x00000000b71ba1e5 evas_async_events_process_blocking (libevas.so.1)
            #4  0x00000000b71af5b8 evas_render_rendering_wait (libevas.so.1)
            #5  0x00000000b71b3335 _evas_canvas_sync (libevas.so.1)
            #6  0x00000000b7136aff evas_canvas_sync (libevas.so.1)
            #7  0x00000000b7139767 evas_sync (libevas.so.1)
            #8  0x00000000b4a49cf6 _ecore_evas_drm_hide (module.so)
            #9  0x00000000b709894e ecore_evas_hide (libecore_evas.so.1)
            #10 0x00000000b4a4fe80 _e_mod_drm_cb_activate (module.so)
            #11 0x00000000b70bef4d _ecore_call_handler_cb (libecore.so.1)
            #12 0x00000000b70bfe22 _ecore_event_call (libecore.so.1)
            #13 0x00000000b70c89b2 _ecore_main_loop_iterate_internal (libecore.so.1)
            #14 0x00000000b70c6bb6 ecore_main_loop_begin (libecore.so.1)
            #15 0x000000000807a259 main (enlightenment)
            #16 0x00000000b6b58527 __libc_start_main (libc.so.6)
            #17 0x00000000080747b1 _start (enlightenment)

GNU gdb (GDB) 7.11
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
http://www.gnu.org/software/gdb/bugs/.
Find the GDB manual and other documentation resources online at:
http://www.gnu.org/software/gdb/documentation/.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/enlightenment...Reading symbols from /usr/lib/debug/usr/bin/enlightenment.debug...done.
done.
[New LWP 8826]
[New LWP 8828]
[New LWP 8825]

warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/enlightenment'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0xb7254cf6 in evas_common_scale_rgba_sample_draw (src=0xa1da2a0, dst=0xa2d7d10, dst_clip_x=6, dst_clip_y=8, dst_clip_w=14, dst_clip_h=5, mul_col=4294967295, render_op=0, src_region_x=0, src_region_y=0, src_region_w=258,

src_region_h=95, dst_region_x=6, dst_region_y=8, dst_region_w=14, dst_region_h=5, mask_ie=0x0, mask_x=0, mask_y=0) at lib/evas/common/evas_scale_sample.c:443

443 *dst_ptr = *ptr;
[Current thread is 1 (Thread 0xb5292b40 (LWP 8826))]
(gdb) bt
#0 0xb7254cf6 in evas_common_scale_rgba_sample_draw (src=0xa1da2a0, dst=0xa2d7d10, dst_clip_x=6, dst_clip_y=8, dst_clip_w=14, dst_clip_h=5, mul_col=4294967295, render_op=0, src_region_x=0, src_region_y=0, src_region_w=258,

src_region_h=95, dst_region_x=6, dst_region_y=8, dst_region_w=14, dst_region_h=5, mask_ie=0x0, mask_x=0, mask_y=0) at lib/evas/common/evas_scale_sample.c:443

#1 0xb7294fa1 in _draw_thread_image_draw (data=0xa24fea0) at modules/evas/engines/software_generic/evas_engine.c:2144
#2 0xb72624fc in evas_thread_worker_func (data=0x0, thread=3039374144) at lib/evas/common/evas_thread_render.c:110
#3 0xb73da5c3 in _eina_internal_call (context=0x9cb0df8) at lib/eina/eina_thread.c:125
#4 0xb6e92291 in start_thread () from /usr/lib/libpthread.so.0
#5 0xb6c26d7e in clone () from /usr/lib/libc.so.6

zmike closed this task as a duplicate of T3576: Crash with GTK.May 11 2016, 10:51 AM