Page MenuHomePhabricator

Source generate functionality
Closed, ResolvedPublic

Description

Check and fix Source generate functionality
"Lazy edc" syntax using.

raster added a subscriber: raster.Apr 27 2016, 4:24 AM

hmmm just a note here. (i am listening to the tickets). ... you know you can't re-generated embryo src from the bytecode it'd be assembly- reproduce edc fully from a stripped binary. the script (embryo) stuff is now compiled bytecode. well technically if you generated src it'd look like assembly... :) it'd be a fairly big effort to generate it then optimize it to be less-assembly like (infer sequences of asm to be higher level things etc.). it'd never be close to the original src though. :(

rimmed added a subscriber: rimmed.Apr 28 2016, 12:44 AM

We try to find the compromise between 'no script' and display the script code. Now it will be generated by edje, but it better than missed script. As point: I have a suggestion: try to get the script source from user code, that included in the edj-file by edje_cc, if it's posible :)

@raster, maybe I am not clear about embryo bytecode, but right now scripts, that generated from edj looks good.
Could you please give example, where is generated embryo script impossible receive as text from Edje?

edj files allow removal of sourc. samsung wanted this to save disk space. the edc src is compressed and packed into edj files normally. if stripped you cannot get back the original src. you CAN figure out most things from the binary data and create an edc ... except the script. since when it's compiled it really is now just bytecode in the edj file. you cant generate src from that unless like above. :)

eet -l file.edj | grep source

-no-save option to edje_cc doesn't include sources. i warned that this is bad and if used things cannot be re-edited later... but need to save a few dozen kb of disk instead. :)

artem.popov closed this task as Resolved.May 23 2016, 1:36 AM