Page MenuHomePhabricator

Enlightenment Beta: Terminology "randomly jumps to current virtual desktop"
Open, Pending on user inputPublic

Description

In some cases I open terminology on one virtual desktop, do some things, change virtual desktops do some more work and some point later the terminology windows "jump" to the current virtual desktop and have focus, in one instance several terminology windows jumped across at once.

I swapped from e 0.20.7 to the beta recently and I didn't see this issue in the stable release, so far I have only seen it with terminology which is the only elm app i have multiple instances of, I normally also have multiple chromium instances but I haven't seen it there.

simotek created this task.May 8 2016, 5:05 AM
zmike added a comment.May 9 2016, 10:44 AM

Need to know if it also happens with the alpha.

@simotek if you've got more then 1 screen (and radeon), i can confirm with several programs, especially smplayer with multiple instances.

preferences -> interface -> instances > uncheck "use only one running instance of SMPlayer" and run several videos at the same time.

zmike lowered the priority of this task from High to Pending on user input.May 12 2016, 9:29 AM

Going to need a more specific way to see this, I've tested a number of cases and nothing seems to trigger it.

I'm wondering if this is an application specific problem, in this case the way fish is interacting with terminology it often seems to happen a few seconds after a command has finished running but it happens in other cases as well. This morning when I went to a different virtual desktop terminology looked something like this https://www.enlightenment.org/ss/display.php?image=e-57439bbc8370f7.96837609.jpg and when it "jumped" to my current desktop it looked like https://www.enlightenment.org/ss/display.php?image=e-57439a8e703f65.57708129.jpg I'll add @billiob to the cc maybe he knows of something in terminology that could trigger it.

I'm now seeing this on 2 machines, sometimes the terminology window sometimes terminology brings itself to the front of the stack and moves itself to the top left corner if running on the same Virtual Desktop as has focus, I'm going to try and remove all e/efl and terminology config and see if the problem persists

zmike added a comment.Jun 6 2016, 8:09 AM

Can you check and see if you have any related window remembers next time it happens?

So it seems highly likely that this is a theme bug, how or why i'm still trying to figure out. But started happening again when I re added that theme. The source code is https://github.com/simotek/Enlightenment-Themes/tree/anti-transient-color if you have any idea.

simotek closed this task as Invalid.Jun 6 2016, 4:38 PM

So I have found a reproducer for this issue. It seems to happen in any theme with the following lines in edc/elm/win.edc

group { name: "elm/win/base/default";
   data.item: "alpha" "1";

This line is used to make windows transparent / semi transparent.

Is a sample broken theme, If you run it under X11 for a few hours you will almost certainly hit the issue several times. I am also happy to test any patch that you think would theoretically fix the issue. The complete source code is https://github.com/simotek/Enlightenment-Themes/tree/Transient (Note the branch)

simotek reopened this task as Open.Jun 16 2016, 7:58 PM
simotek raised the priority of this task from Pending on user input to Normal.
zmike added a subscriber: raster.Jun 17 2016, 7:53 AM

That's pretty strange. I guess that's somehow changing the attributes that are used for remembers?

I don't currently have any remembers setup at the moment so I don't think its that, maybe its a elm bug or changes the window type it also sometimes causes issues with terminology in the pager if it hasn't been repainted for a while.

zmike lowered the priority of this task from Normal to Pending on user input.Aug 17 2017, 12:36 PM

I just tested this again with the attached theme and can't reproduce it.