Page MenuHomePhabricator

[BUG] fileselector SIGSEGV issues (probably promise?)
Closed, ResolvedPublic

Description

  1. run fileselector example from elementary_test

elementary_test -to fileselector

  1. open any folder
  2. create new file called "111.txt" in that folder (sometimes SIGSEGV №1 or №2 here) in different way
  3. open file, modify, add strings and save (SIGSEGV №2 for sure)

Interesting that if I don't change current folder (fileselector still on my home directory) all changes and stuff above actually works well.

I also made some videos (~12 mb each) showing the case
creating file:


modifying file:

If you can't reproduce at first, try different ways of file creating/modifying.
I tried creating/modifying by touch, vim, nautilus and enlightenment_filemanager so far.
Weird but some of them provoke such failings, some are not.

-----------------SIGSEGV number 1------------------------

Program received signal SIGSEGV, Segmentation fault.
eina_list_append (list=0x48, data=0x0) at lib/eina/eina_list.c:565
(gdb) bt
#0 eina_list_append (list=0x48, data=0x0) at lib/eina/eina_list.c:565
#1 0x00007ffff7bd0b45 in _efl_model_evt_added_ecore_cb (data=0x55555610ac50, type=<optimized out>, event=0x555555f93d70) at lib/eio/eio_model.c:146
#2 0x00007ffff6e37fa9 in _ecore_call_handler_cb (event=<optimized out>, type=<optimized out>, data=<optimized out>, func=<optimized out>) at lib/ecore/ecore
_private.h:312
#3 _ecore_event_call () at lib/ecore/ecore_events.c:518
#4 0x00007ffff6e3eb05 in _ecore_main_loop_iterate_internal (once_only=once_only@entry=0) at lib/ecore/ecore_main.c:2342
#5 0x00007ffff6e3eea7 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:1284
#6 0x0000555555578089 in elm_main (argc=<optimized out>, argv=<optimized out>) at bin/elementary/test.c:1049
#7 0x000055555557590f in main (argc=1, argv=0x7fffffffe438) at bin/elementary/test.c:1063
(gdb)

----------------SIGSEGV number 2 -------------------------

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7bd0a55 in _efl_model_evt_deleted_ecore_cb (data=0x555555d17d20, type=<optimized out>, event=0x555555f455a0) at lib/eio/eio_model.c:173
(gdb) bt
#0 0x00007ffff7bd0a55 in _efl_model_evt_deleted_ecore_cb (data=0x555555d17d20, type=<optimized out>, event=0x555555f455a0) at lib/eio/eio_model.c:173
#1 0x00007ffff6e37fa9 in _ecore_call_handler_cb (event=<optimized out>, type=<optimized out>, data=<optimized out>, func=<optimized out>) at lib/ecore/ecore
_private.h:312
#2 _ecore_event_call () at lib/ecore/ecore_events.c:518
#3 0x00007ffff6e3eb05 in _ecore_main_loop_iterate_internal (once_only=once_only@entry=0) at lib/ecore/ecore_main.c:2342
#4 0x00007ffff6e3eea7 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:1284
#5 0x0000555555578089 in elm_main (argc=<optimized out>, argv=<optimized out>) at bin/elementary/test.c:1049
#6 0x000055555557590f in main (argc=1, argv=0x7fffffffe438) at bin/elementary/test.c:1063
(gdb)

Hi @FurryMyad I'm trying reproduce this bug without successes, I made some changes in my workspace to do eio_model more stable (based in this report) but I cant reproduce this error, I tried with

21315509e20c332f15e183f073adbf25ef193d86

which efl version you used?

Updated my efl version but sadly it still reproduces on my system

~ $ lsb_release -d -s
Ubuntu 14.04.4 LTS
~ $ uname -r
3.13.0-87-generic

Efl Version: 1.17.99.48568
My top commit now is

commit c6dfdeb0c8d0122c848e959cfb73d529c44d5176
Author: Jean-Philippe Andre <jp.andre@samsung.com>
Date: Tue Jun 14 16:20:51 2016 +0900

billiob removed a subscriber: efl.Jun 14 2016, 2:33 AM
NikaWhite added a subscriber: NikaWhite.EditedJun 14 2016, 4:09 AM

Hi All,
For me this is reproduced by next steps:

  1. elementary_test -to fileselector
  2. Create new *.txt file in the same directory, that opened in fileselector test app.

Result: Thread 1 "elementary_test" received signal SIGSEGV, Segmentation fault.

bt:
#0 eina_list_append (list=0xffffffffffffffff, data=0x0) at lib/eina/eina_list.c:565
#1 0x00007ffff7bd00c5 in _efl_model_evt_added_ecore_cb (data=0x555555e5ee50, type=<optimized out>, event=0x555555f48b40) at lib/eio/eio_model.c:146
#2 0x00007ffff6e37b4d in _ecore_call_handler_cb (event=<optimized out>, type=<optimized out>, data=<optimized out>, func=<optimized out>) at lib/ecore/ecore_private.h:312
#3 _ecore_event_call () at lib/ecore/ecore_events.c:518
#4 0x00007ffff6e3e5d8 in _ecore_main_loop_iterate_internal (once_only=once_only@entry=0) at lib/ecore/ecore_main.c:2342
#5 0x00007ffff6e3e957 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:1284
#6 0x0000555555577dc3 in elm_main (argc=<optimized out>, argv=<optimized out>) at bin/elementary/test.c:1049

efl version is current HEAD from git in master branch.

cedric added a subscriber: cedric.Jun 14 2016, 8:47 AM

Can you give a valgrind back trace ?

Hi All

I Fixed the eio_monitor in Eio_Model in commit

3f1466b77d804b6a47dd5e092615d8d3c91a2b5c

probable that resolve this bug

It is works for me. Thanks.
We are need to wait feedback from @FurryMyad before close this ticket.

Yup! Everything is fine-working for me as well, thank you very much!

Here, take Pterodactyl for your work C:

FurryMyad rescinded a token.
FurryMyad closed this task as Resolved.
FurryMyad awarded a token.