Page MenuHomePhabricator

E Filemanager and Fileselector are fighting, this leads to high CPU and occasional crashes
Closed, InvalidPublic

Description

  1. Open efm to ~
  2. Open set wallpaper dialog
  3. Press the picture button in the set wallpaper dialog to choose a new wallpaper
  4. Watch the crazyness begin with both dialogs constantly refreshing and eating all the CPU's a. One time toggling show all files led to an eventual crash.
  5. File a bug report with a video
simotek created this task.Jun 20 2016, 5:13 PM

EFm is also being refreshed while cycling through menu options

Ok so this is a issue with my theme somehow

Here is the theme

Unlike T3604 this doesn't use alpha background windows

The difference with this theme is it uses "image.border_scale_by: 0.25; image.border_scale: 1;" in multiple places so its probably a efl bug and related to T3309

simotek removed zmike as the assignee of this task.Jun 20 2016, 5:55 PM
simotek raised the priority of this task from High to Incoming Queue.
simotek edited projects, added efl; removed enlightenment-git.
simotek added subscribers: raster, zmike.
jpeg triaged this task as Pending on user input priority.Jul 28 2016, 1:11 AM
jpeg added a subscriber: jpeg.

@simotek, I can't reproduce this issue with the provided theme file.

jpeg closed this task as Invalid.Feb 21 2017, 1:35 AM

I think this is no longer an issue. I tested with the provided theme as well as with the default theme.