Page MenuHomePhabricator

enlightenment crashes on setup phase
Closed, InvalidPublic

Description

To reproduce:

  • mv ~/.e ~/.ecore ~/.elementary /path/to/backup-directory
  • Start enlightenment from DM (I used sddm)
  • Proceed with the setup and only select "Next". Fails at the third one.

crashdump attached

. Unfortunately, I don't see all symbols even after compiling with CFLAGS="-pipe -g -ggdb3". If I get some time, I will try later to compile it manually instead of via emerge. Using enlightenment from git, updated about a half hour ago, which should correspond to this commit.

EFL information is:

>>> Unpacking source...
GIT update -->
   repository:               git://git.enlightenment.org/core/efl.git
   at the commit:            2d4ea75d47a63912d5cb5692ab33b6bd839f73df
   branch:                   master
   storage directory:        "/usr/portage/distfiles/egit-src/enlightenment/core/efl"
   checkout type:            bare repository
Cloning into '/tmp/var_tmp/portage/dev-libs/efl-9999/work/efl-9999'...
done.
ppurka created this task.Jun 21 2016, 7:12 AM
zmike triaged this task as High priority.Jun 21 2016, 8:51 AM
zmike edited projects, added Restricted Project, efl; removed enlightenment-git.
zmike reassigned this task from zmike to jpeg.
jpeg added a comment.EditedJun 21 2016, 5:34 PM

Unfortunately, I don't see all symbols even after compiling with CFLAGS="-pipe -g -ggdb3"

You also need -O0 otherwise you get symbols as <optimized out>.

I first wrote:

I have observed this crash as well, didn't have time to look at it yet.
This seems to happen only with the GL engine, not with SW.

I haven't seen this crash yet. (Totally unrelated with the quote above)

stefan_schmidt removed a project: Restricted Project.Jul 20 2016, 7:38 AM
raster closed this task as Invalid.Jul 20 2016, 8:09 PM
raster added a subscriber: raster.

i know you may not want to hear this but... current git master efl and enlightenment, running through startup wizard under valgrind even and zero complaints. no segfaults. no invalid accesses. nothing. i can't reproduce the issue at all. i'm going to mark this as invalid because i can't reproduce a single thing here. if you find more info - please re-open or open a new bug. for now i can only conclude this has been fixed by now.

I believe whatever fixed T3918 also fixed this issue. Thanks for having a look.