Page MenuHomePhabricator

[bug] segfault on Shourtcust Ctrl-s
Closed, ResolvedPublic

Description

run eflete, open/load some project, do some changes in this project and press Ctrl-s

Process: eflete [90039]
Path: /usr/local/bin/eflete
Identifier: eflete
Version: 0
Code Type: X86-64 (Native)
Parent Process: bash [95809]
Responsible: Terminal [229]
User ID: 501

Date/Time: 2016-06-23 12:25:27.505 +0300
OS Version: Mac OS X 10.9.5 (13F1808)
Report Version: 11
Anonymous UUID: E4F93FF4-4CC1-A8C9-CEC0-E95BAC7A4B09

Sleep/Wake UUID: 19110D10-09A5-4040-A070-79A13A1C2EDB

Crashed Thread: 8

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

VM Regions Near 0:
-->

__TEXT                 000000010fc52000-000000010fd47000 [  980K] r-x/rwx SM=COW  /usr/local/bin/eflete

Thread 0:: Dispatch queue: com.apple.main-thread
0 libsystem_kernel.dylib 0x00007fff8c4f9716 __psynch_cvwait + 10
1 libsystem_pthread.dylib 0x00007fff8e0c3c3b _pthread_cond_wait + 727
2 libecore.1.dylib 0x0000000110b6f837 eina_condition_wait + 39
3 libecore.1.dylib 0x0000000110b70266 _ecore_main_call_flush + 230
4 libecore.1.dylib 0x0000000110b6e788 _thread_callback + 24
5 libecore.1.dylib 0x0000000110b822ec _ecore_pipe_handler_call + 124
6 libecore.1.dylib 0x0000000110b814b2 _ecore_pipe_read + 882
7 libecore.1.dylib 0x0000000110b7e912 _ecore_call_fd_cb + 34
8 libecore.1.dylib 0x0000000110b7e5b3 _ecore_main_fd_handlers_call + 275
9 libecore.1.dylib 0x0000000110b7baa5 _ecore_main_loop_iterate_internal + 517
10 libecore.1.dylib 0x0000000110b7bb55 ecore_main_loop_iterate_may_block + 69
11 eflete 0x000000010fc54b34 eflete_main_loop_begin + 36
12 eflete 0x000000010fca9c81 project_save + 273
13 eflete 0x000000010fca52a3 _menu_cb + 131
14 libecore.1.dylib 0x0000000110b74588 _ecore_call_handler_cb + 40
15 libecore.1.dylib 0x0000000110b74007 _ecore_event_call + 503
16 libecore.1.dylib 0x0000000110b7bac8 _ecore_main_loop_iterate_internal + 552
17 libecore.1.dylib 0x0000000110b7bc53 ecore_main_loop_begin + 211
18 libelementary.1.dylib 0x000000010ff2c2d9 elm_run + 9
19 eflete 0x000000010fc54651 elm_main + 3809
20 eflete 0x000000010fc549f1 main + 65
21 libdyld.dylib 0x00007fff917d95fd start + 1

its bug not only for Shortcut Ctrl-s
Eflete can't save any changes in project due to segfault

report from gdb:

Thread 14 received signal SIGSEGV, Segmentation fault.
0x00007fff9355e887 in ?? () from /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
(gdb) bt
#0 0x00007fff9355e887 in ?? () from /System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib
#1 0x000000011187fd80 in ?? ()
#2 0x00000001061259cf in evas_gl_texture_pool_empty () from /usr/local/lib/evas/modules/engines/gl_cocoa/v-1.17/module.so
Backtrace stopped: frame did not save the PC

also need check edje_object_mmap_set function

segfault in evas_object_smart_callback_call(ap.win, SIGNAL_EDITOR_SAVED, NULL);
inside - eo_event_callback_call(eo_obj, eo_desc, event_info);

se.osadchy added a comment.EditedJul 4 2016, 12:33 AM

after callback call _editor_save in tabs.c and we have segfault after call edje_object_mmap_set in gm_group_edit_object_reload

if in empty project add empty_group and save - all work
but if save project after adding part - segfault

after investigate - issue due to renderer with set proxy texture
part type swallow, text, program etc adding and saved correctly
only part type RECTANGLE not save

example for reproduce bug:

Thread 9 Crashed:
0 libGL.dylib 0x00007fff9355e887 glDeleteTextures + 18
1 module.so 0x0000000112c689cf evas_gl_texture_pool_empty + 479 (evas_gl_texture.c:950)
2 module.so 0x0000000112c68d7a pt_unref + 282 (evas_gl_texture.c:982)
3 module.so 0x0000000112c6a245 evas_gl_common_texture_free + 389 (evas_gl_texture.c:1474)
4 module.so 0x0000000112c71832 evas_gl_common_image_free + 306 (evas_gl_image.c:716)
5 module.so 0x0000000112c46063 eng_image_free + 67 (evas_engine.c:586)
6 libevas.1.dylib 0x000000010dcac64c _evas_image_proxy_unset + 236 (efl_canvas_proxy.c:178)
7 libevas.1.dylib 0x000000010dbfa4e3 _evas_image_cleanup + 291 (evas_object_image.c:134)
8 libevas.1.dylib 0x000000010dcac266 _evas_image_proxy_source_set + 790 (efl_canvas_proxy.c:50)
9 libevas.1.dylib 0x000000010dbf5791 evas_object_image_source_unset + 129 (evas_image_legacy.c:409)
10 libevas.1.dylib 0x000000010dc0f942 _efl_canvas_object_eo_base_destructor + 1106 (evas_object_main.c:796)
11 libeo.1.dylib 0x000000010e5eb23d eo_destructor + 221 (eo_base.eo.c:82)
12 libeo.1.dylib 0x000000010e5e4afe _eo_del_internal + 110 (eo_private.h:233)
13 libeo.1.dylib 0x000000010e5e0186 _eo_unref + 454 (eo_private.h:353)
14 libeo.1.dylib 0x000000010e5e0251 _eo_call_end + 65 (eo.c:475)
15 libeo.1.dylib 0x000000010e5eaf26 eo_del + 230 (eo_base.eo.c:70)
16 libevas.1.dylib 0x000000010dc0c8f7 evas_object_del + 311 (evas_object_main.c:737)
17 libedje.1.dylib 0x000000010d9e1a4a _edje_file_del + 1210 (edje_load.c:1662)
18 libedje.1.dylib 0x000000010d9dda2a _edje_object_file_set_internal + 538 (edje_load.c:538)
19 libedje.1.dylib 0x000000010d9fd953 _edje_object_efl_file_mmap_set + 83 (edje_smart.c:432)
20 libefl.1.dylib 0x000000010e588198 efl_file_mmap_set + 248 (efl_file.eo.c:6)
21 libedje.1.dylib 0x000000010d9fad05 edje_object_mmap_set + 37 (edje_smart.c:452)
22 eflete 0x000000010d1f5ad6 gm_group_edit_object_reload + 262 (group_manager.c:70)
23 eflete 0x000000010d25cc7d _editor_saved + 125 (tabs.c:462)
24 libevas.1.dylib 0x000000010dc24d6b _eo_evas_smart_cb + 75 (evas_object_smart.c:71)
25 libeo.1.dylib 0x000000010e5e7398 _eo_base_event_callback_call + 952 (eo_base_class.c:1130)
26 libeo.1.dylib 0x000000010e5ebfe8 eo_event_callback_call + 248 (eo_base.eo.c:134)
27 libevas.1.dylib 0x000000010dc25264 evas_object_smart_callback_call + 132 (evas_object_smart.c:840)
28 eflete 0x000000010d21b8bd _editor_save + 221 (editor_general.c:34)
29 eflete 0x000000010d21b8ea editor_save_all + 26 (editor_general.c:46)
30 eflete 0x000000010d1fc9e2 _project_save + 162 (project_manager.c:786)
31 libeina.1.dylib 0x000000010e64d441 _eina_internal_call + 129 (eina_thread.c:125)
32 libsystem_pthread.dylib 0x00007fff943d2899 _pthread_body + 138
33 libsystem_pthread.dylib 0x00007fff943d272a _pthread_start + 137
34 libsystem_pthread.dylib 0x00007fff943d6fc9 thread_start + 13

Check patch for fix bug:

se.osadchy closed this task as Resolved.Jul 12 2016, 12:50 AM
se.osadchy claimed this task.