Page MenuHomePhabricator

[Bug] Segmentation fault after click "root" button on the Home tab
Closed, ResolvedPublic

Description

[Steps]

  1. Run eflete
  2. Click on 'root' button in the bottom part of Home tab

[Actual]
Program received signal SIGSEGV, Segmentation fault.

[Expected]
Root folder should be opened

bt:

#0  eina_stringshare_del (
    str=0x98761233 <error: Cannot access memory at address 0x98761233>)
    at lib/eina/eina_stringshare.c:545
#1  0x00007ffff773bd54 in _listing_request_cleanup (lreq=0xb48950, 
    lreq@entry=<error reading variable: Cannot access memory at address 0x7fffffffdec8>) at lib/elementary/elc_fileselector.c:799
QA_Igor created this task.Jul 27 2016, 5:16 AM
QA_Igor updated the task description. (Show Details)
an.kroitor closed this task as Invalid.Jul 28 2016, 3:51 AM
an.kroitor added a subscriber: an.kroitor.

I've tried few times still can't reproduce this. Maybe some steps are missing

I've updated to version 1a544db6 . Just first run of Eflete and crash happened.

QA_Igor reopened this task as Open.Jul 28 2016, 5:56 AM
rimmed updated the task description. (Show Details)Jul 28 2016, 8:06 AM
rimmed claimed this task.Aug 9 2016, 7:25 AM
rimmed edited projects, added Eflete (Component Designer 0.7.0); removed Eflete.
rimmed triaged this task as Showstopper Issues priority.
rimmed added a comment.Aug 9 2016, 9:20 AM

Please update the efl.
Can not reproduce, please check again

rimmed lowered the priority of this task from Showstopper Issues to Incoming Queue.

Can not reproduce too.

rimmed triaged this task as Showstopper Issues priority.
rimmed closed this task as Resolved.Aug 15 2016, 5:04 AM