Page MenuHomePhabricator

[Bug] Segmentation fault when delete used sound in program
Closed, InvalidPublic

Description

Steps:

  1. Add sound to Sound manager
  2. Add program with action Play sample
  3. Actions params > Sample > select added sound
  4. Open Sound manager
  5. Delete used sound

Actual:
Program received signal SIGSEGV, Segmentation fault.

Expected:

bt:

0  __strcmp_ssse3 () at ../sysdeps/x86_64/multiarch/../strcmp.S:209
1  0x00007ffff623bd88 in _delete_play_actions (
    obj=obj@entry=0x4000047de0005df2, 
    name=name@entry=0x18d1c0c "Alesis-S4-Plus-Clean-Gtr-C4.wav", 
    action_type=action_type@entry=13, eetf=eetf@entry=0x7c1af0)
    at lib/edje/edje_edit.c:1084
2  0x00007ffff623c8db in _delete_play_actions (eetf=0x7c1af0, action_type=13, 
    name=0x18d1c0c "Alesis-S4-Plus-Clean-Gtr-C4.wav", obj=0x4000047de0005df2)
    at lib/edje/edje_edit.c:1263
3  edje_edit_sound_sample_del (obj=0x4000047de0005df2, 
    name=0x18d1c0c "Alesis-S4-Plus-Clean-Gtr-C4.wav")
    at lib/edje/edje_edit.c:1260
4  0x00000000004a542f in _sound_del_cb (data=<optimized out>, 
    obj=<optimized out>, event_info=<optimized out>)
    at ../../src/bin/ui/sound_manager.c:448
5  0x00007ffff5fc894c in _eo_base_event_callback_call (
    obj_id=<optimized out>, pd=0x1642f50, 
    desc=0x7ffff717d400 <_EFL_UI_EVENT_CLICKED>, event_info=<optimized out>)
    at lib/eo/eo_base_class.c:1176
6  0x00007ffff5fc5edb in eo_event_callback_call (obj=0x40000167d0007f75, 
    desc=0x7ffff717d400 <_EFL_UI_EVENT_CLICKED>, event_info=0x0)
    at lib/eo/eo_base.eo.c:142
7  0x00007ffff6278350 in edje_match_callback_exec_check_finals (
QA_Igor created this task.Jul 28 2016, 11:36 PM
rimmed updated the task description. (Show Details)Jul 29 2016, 7:23 AM

cant reproduce for now

FurryMyad claimed this task.Aug 5 2016, 4:21 AM
FurryMyad set the point value for this task to 0.
FurryMyad removed FurryMyad as the assignee of this task.
FurryMyad removed the point value for this task.
FurryMyad moved this task from Component Designer 0.7.0 to KanBan (Bugs pool) on the Eflete board.
FurryMyad edited projects, added Eflete; removed Eflete (Component Designer 0.7.0).
NikaWhite closed this task as Invalid.Aug 19 2016, 10:41 AM
NikaWhite added a subscriber: NikaWhite.

Not reproduce