Page MenuHomePhabricator

E crash from closing Qt app
Closed, ResolvedPublic

Description

No idea if the app does something weird since it doesn't happen with all other Qt apps but here goes.

[Current thread is 1 (Thread 0xb58c97c0 (LWP 577))]
(gdb) bt
#0  0x081cf6d9 in _e_comp_wl_client_cb_del (data=0x0, ec=0x8a705b8) at src/bin/e_comp_wl.c:2439
#1  0x080938a6 in _e_client_hook_call (hookpoint=E_CLIENT_HOOK_DEL, ec=0x8a705b8) at src/bin/e_client.c:316
#2  0x080948ae in _e_client_del (ec=0x8a705b8) at src/bin/e_client.c:638
#3  0x0815d145 in e_object_del (obj=0x8a705b8) at src/bin/e_object.c:59
#4  0x081cde19 in _e_comp_wl_surface_destroy (resource=0x8ae91c8) at src/bin/e_comp_wl.c:1757
#5  0xb6e8bab3 in destroy_resource (element=0x8ae91c8, data=0xbf907b38) at src/wayland-server.c:571
#6  0xb6e920fd in for_each_helper (entries=0x8ca0518, func=0xb6e8ba49 <destroy_resource>, data=0xbf907b38) at src/wayland-util.c:372
#7  0xb6e92131 in wl_map_for_each (map=0x8ca0518, func=0xb6e8ba49 <destroy_resource>, data=0xbf907b38) at src/wayland-util.c:378
#8  0xb6e8bdae in wl_client_destroy (client=0x8ca04f8) at src/wayland-server.c:709
#9  0xb6e8b3bf in wl_client_connection_data (fd=94, mask=5, data=0x8ca04f8) at src/wayland-server.c:248
#10 0xb6e8e0c6 in wl_event_source_fd_dispatch (source=0x87fa500, ep=0xbf907c2c) at src/event-loop.c:88
#11 0xb6e8eb46 in wl_event_loop_dispatch (loop=0x8422ae0, timeout=0) at src/event-loop.c:421
#12 0xb6ea84ee in _cb_create_data (data=0x8422a20, hdl=0x8366a88) at lib/ecore_wl2/ecore_wl2_display.c:238
#13 0xb6df48f6 in _ecore_call_fd_cb (func=0xb6ea84b4 <_cb_create_data>, data=0x8422a20, fd_handler=0x8366a88) at lib/ecore/ecore_private.h:333
#14 0xb6df6ccc in _ecore_main_fd_handlers_call () at lib/ecore/ecore_main.c:1974
#15 0xb6df72f8 in _ecore_main_loop_iterate_internal (once_only=0) at lib/ecore/ecore_main.c:2339
#16 0xb6df5571 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:1286
#17 0x0807a266 in main (argc=1, argv=0xbf941014) at src/bin/e_main.c:1082
(gdb)