Page MenuHomePhabricator

E21+ E_FM Preview Freeze
Closed, ResolvedPublic

Description

Hi. E freezes.

Open EFM and hover over an icon (media) to show the preview dialogue.

With a video or audio file the preview will play normally..however after around 30 seconds of the preview in the dialogue all input and video freezes. Have to restart E. Of note the music/audio of the video continues playing.

E21 and E git w/EFL git.

netstar created this task.Sep 9 2016, 4:18 PM

Can't reproduce atm but it's happened 1 time before.

Will post a bt then.

you know the drill. BT! :)

This wasn't a media file.

Selected a text file (had focus in EFM), then mouse over and wait for preview...(the preview box was empty)... then moved the cursor back over the file (in EFM) and the thing crashed...I got a backtrace, it's in here:

hmmm what file is that?

  1. hostapd configuration file

is what it starts with. the bt says it's 8192 bytes long. is it really? that smells like rounded up to the next page. eina_file_map_new() seems to be missing gdb info - missing params. what is file->length? the code seems to check if this here is all ok... but 8192 seems suspicious. even then... the only reason to seg there would be the mapping is wrong Or a disk i/o error and that should be a sigbus not sigsegv. try inspecting the func _eina_file_map_populate() and what s is, i is, size is, etc. vars.

Okay...will look into that. Yeah it's not 8192 in size.

There you go :

file is 71477 size in bytes;

s and i are 8192!

Other files do the same. size and i as 8192.

It doesn't happen every time. Just "some" files in EFM.

Didnt print the flie size from the eio call in efm's preview code though but that *should* be okay surely to goodness!

netstar closed this task as Resolved.Sep 21 2016, 12:48 AM

haha! oops! we are okay!

#define FILEPREVIEW_TEXT_PREVIEW_SIZE 8192

:D

netstar reopened this task as Open.Sep 21 2016, 12:53 AM

Reopen again! I forgot the original issue...

still awaiting a bt for that w/media previews!

netstar closed this task as Resolved.Sep 21 2016, 1:20 AM

Actually I can't reproduce the original crash and I'm testing it hard...I'll close...I difnt get the bt originally...we got two anyway!

umm so file is bigger than 8192 so 8192 is fine.. its the first 8k of the file. the first gdb doesnt make sense.. but the 2nd i think its a lack of nul byte termination of the string.