Page MenuHomePhabricator

E git crasg
Closed, ResolvedPublic

Description

AM not sure how to reproduce this one.

Three displays using OpenBSD E git and EFL git (as of today), on one display I was running youtuble fully expanded. I clicked to close the window and E crashes.

I attach the backtrace. If this isn't useful I can close as it seems "transient" and difficult to reproduce.

Related Objects

Mentioned In
T4798: E_fm Crash
Mentioned Here
T4798: E_fm Crash
netstar created this task.Oct 7 2016, 11:17 AM

Slightly ambiguous there. Full-screen Chromium browser.

aaaah crap. ecore animators stoped being eo objects undernesath - @cedirc changed this. @cedric - why don't we just return to them being eo objects but not installing the .eo file?

Sorry for the noise...keep this one open for now???

i looked at undoing the patch. more work. @cedric - what do u think of just bringing back the eo code for animators but making the eo file/class legacy. just so we have eo protection for animators.

I've another backtrace here not sure if it relates:

Sorry I didn't even read it...that is not related. New ticket!

a sigbus that is NOT in a mmaped file? e should have spewed out an error just before the sigbus like:

ERR("Unaligned memory access - BUS_ADRALN. SIGBUS!!!");
ERR("Invalid object - BUS_OBJERR. SIGBUS!!!");
ERR("Memory Fault - BUS_MCEERR_AR. SIGBUS!!!");
ERR("Memory Fault - BUS_MCEERR_AO. SIGBUS!!!");
ERR("Memory Fault - Unknown. SIGBUS!!!");

one of those above. unaligned access. but... what? this is on x86? in fact...

evas_object_geometry_get(ic->obj, &xx, &yy, &ww, &hh);

that's line 2361 in e_fm.c. ic must be bad. and looking at it... it is: 0xdfdfdfdfdfdfdfdf .... that's certainly unaligned ... so the parent function that calls this is doing:

e_fm2_icon_geometry_get(fwin->popup_icon->ic, &x, &y, &w, &h);

well fwin->popup_icon->ic must be junk... somehow. so popup_icon content must have been junked... by something. perhaps freed and then used so now the mem is recycled. i smell a lifecycle bug with popup_icon here. its set from event info om a smart cb and there is a good chance its deleted via a refresh or some other mechanism. it's intended to be used within the cb only. storing it for longer is not intended...

this now is covered in T4798

raster closed this task as Resolved.Oct 31 2016, 2:26 AM