Page MenuHomePhabricator

Focus change to monitor 1 from 2 does not work
Closed, ResolvedPublic

Description

After upgrading to efl 1.18.4, I had to remove the .e folder because enlightenment started with a black screen. That problem has been resolved by eliminating the existing configuration and starting anew. The problem is that now whenever the focus changes to the second monitor I can't focus back to the first monitor. I see the window titlebars changing focus with the mouse on the second monitor, but nothing on first monitor. I can even click into the address field of a firefox on first monitor and get the input cursor, the text I type goes to the focused window on monitor 2, though. A very awkward workaround is to move the window I want to focus to monitor 2 and move it back to monitor 1 again.

Focus settings:
Basic:
La ventana más reciente debajo del raton (should be something like "Most recent window under the mouse")
Elevar las ventanas al pasar el ratón por encima (raise windows on mouse over)

Advanced:
Focus:
policy: Sloppy
On new windows: Only dialog boxes with focused parent

Apilamiento:
autoraise: Raise window on mouseover delay 1s
raise window: start moving or resizing

Hints: activate on hint

Pointer: move pointer to newly focused window active

other:
pass click events always to programs
focus last focused window on lost focus

nvidia driver 340.98
x server x.org 1.16.4 (11604000)
X screen information:
screen #0
dimensions: 3840x1080 pixels
GPUs NVS 3100M
Displays:
Samsung SMBX2231 (DFP-1)
Lenovo Group Limited (DFP-0)

virtual desktops set to 1x1 configuration.

Not sure if this is efl or enlightenment related...

Weird.... after closing and reopening the session the problem is gone. There might be some problem with some parts of the initial configuration only being used in the next session.

stefan_schmidt closed this task as Resolved.Feb 10 2017, 6:00 AM
stefan_schmidt claimed this task.