Page MenuHomePhabricator

Wayland clients register animators they shouldn't need
Closed, ResolvedPublic

Description

I'm trying to get wayland clients to pace based on frame callbacks, and it's showing some interesting quirks of our client implementation.

Right now when I start terminology it registers an animator for the cursor immediately, even if it's not displaying one. This will remain registered until I mouse in, then out, then back into the app.

That results in running the timer tick thread currently, but when ticking off frame callbacks it means both the compositor and the client will need to wake 60 times per second when there's nothing to display. Not ideal for battery life...

Related Objects

ManMower created this task.Feb 23 2017, 1:16 PM

Thanks for the memo derek ;) On it Monday...

devilhorns triaged this task as Normal priority.Feb 27 2017, 5:40 AM

Small patch which hopefully fixes the issue. Please let me know

devilhorns removed devilhorns as the assignee of this task.Mar 1 2017, 10:16 AM
devilhorns reopened this task as Open.
devilhorns added a subscriber: devilhorns.
zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 6:58 AM
q66 edited projects, added efl: display system; removed Restricted Project.Jun 11 2018, 7:49 AM
ManMower closed this task as Resolved.Jun 11 2018, 9:28 AM
ManMower claimed this task.

I can't reproduce this anymore, there have been lots of related animator commits since, I suspect one of those fixed it.