Page MenuHomePhabricator

Xwayland resizes crash E
Closed, ResolvedPublic

Description

To rep. Start xterm resize vigorously.

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/enlightenment'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0xb6b29649 in __memcpy_ssse3 () from /usr/lib/libc.so.6
[Current thread is 1 (Thread 0xb5790d80 (LWP 21595))]
(gdb) bt
#0  0xb6b29649 in __memcpy_ssse3 () at /usr/lib/libc.so.6
#1  0xacc14000 in _GLOBAL_OFFSET_TABLE_ () at /usr/lib/xorg/modules/dri/i915_dri.so
#2  0xac52d6ce in _mesa_texstore_memcpy (ctx=0xa638be0, dims=2, baseInternalFormat=6408, dstFormat=MESA_FORMAT_B8G8R8A8_UNORM, dstRowStride=4096, dstSlices=0xbf970194, srcWidth=688, srcHeight=446, srcDepth=1, srcFormat=32993, srcType=5121, srcAddr=0x8dfb8000, srcPacking=0xa650a20) at main/texstore.c:899
#3  0xac52d719 in _mesa_texstore (ctx=0xa638be0, dims=2, baseInternalFormat=6408, dstFormat=MESA_FORMAT_B8G8R8A8_UNORM, dstRowStride=4096, dstSlices=0xbf970194, srcWidth=688, srcHeight=446, srcDepth=1, srcFormat=32993, srcType=5121, srcAddr=0x8dfb8000, srcPacking=0xa650a20) at main/texstore.c:916
#4  0xac52db4a in store_texsubimage (ctx=0xa638be0, texImage=0xa96ce28, xoffset=1, yoffset=1, zoffset=0, width=688, height=446, depth=1, format=32993, type=5121, pixels=0x8dfb8000, packing=0xa650a20, caller=0xaca6c4fe "glTexSubImage") at main/texstore.c:1075
#5  0xac52dcdf in _mesa_store_texsubimage (ctx=0xa638be0, dims=2, texImage=0xa96ce28, xoffset=1, yoffset=1, zoffset=0, width=688, height=446, depth=1, format=32993, type=5121, pixels=0x8dfb8000, packing=0xa650a20)
    at main/texstore.c:1139
#6  0xac7f4ec3 in intelTexSubImage (ctx=0xa638be0, dims=2, texImage=0xa96ce28, xoffset=1, yoffset=1, zoffset=0, width=688, height=446, depth=1, format=32993, type=5121, pixels=0x8dfb8000, packing=0xa650a20)
    at intel_tex_subimage.c:144
#7  0xac51baed in _mesa_texture_sub_image (ctx=0xa638be0, dims=2, texObj=0xb2ec338, texImage=0xa96ce28, target=3553, level=0, xoffset=1, yoffset=1, zoffset=0, width=688, height=446, depth=1, format=32993, type=5121, pixels=0x8dfb8000, dsa=false) at main/teximage.c:3239
#8  0xac51bc1a in texsubimage (ctx=0xa638be0, dims=2, target=3553, level=0, xoffset=1, yoffset=1, zoffset=0, width=688, height=446, depth=1, format=32993, type=5121, pixels=0x8dfb8000, callerName=0xaca6ab4a "glTexSubImage2D")
    at main/teximage.c:3297
#9  0xac51bee3 in _mesa_TexSubImage2D (target=3553, level=0, xoffset=1, yoffset=1, width=688, height=446, format=32993, type=5121, pixels=0x8dfb8000) at main/teximage.c:3438
#10 0xb0e2cf11 in _tex_sub_2d (gc=0xa4574d0, x=1, y=1, w=688, h=446, fmt=32993, type=5121, pix=0x8dfb8000) at modules/evas/engines/gl_common/evas_gl_common.h:900
#11 0xb0e2fc2a in evas_gl_common_texture_upload (tex=0xa96cd48, im=0xa8adb80, bytes_count=4) at modules/evas/engines/gl_common/evas_gl_texture.c:1188
#12 0xb0e30d41 in evas_gl_common_texture_update (tex=0xa96cd48, im=0xa8adb80) at modules/evas/engines/gl_common/evas_gl_texture.c:1551
#13 0xb0e2e121 in evas_gl_common_texture_new (gc=0xa4574d0, im=0xa8adb80, disable_atlas=0 '\000') at modules/evas/engines/gl_common/evas_gl_texture.c:588
#14 0xb0e3778a in evas_gl_common_image_update (gc=0xa4574d0, im=0xb6d2cc0) at modules/evas/engines/gl_common/evas_gl_image.c:960
#15 0xb0e386ff in evas_gl_common_image_draw (gc=0xa4574d0, im=0xb6d2cc0, sx=0, sy=0, sw=688, sh=446, dx=0, dy=23, dw=688, dh=446, smooth=0) at modules/evas/engines/gl_common/evas_gl_image.c:1275
#16 0xb0e10dc7 in eng_image_draw (data=0xa285570, context=0xa804bb8, surface=0xb70cbd8, image=0xb6d2cc0, src_x=0, src_y=0, src_w=688, src_h=446, dst_x=0, dst_y=23, dst_w=688, dst_h=446, smooth=0, do_async=0 '\000')
    at modules/evas/engines/gl_generic/evas_engine.c:1206
#17 0xb714224e in _draw_image (obj=0xab48b90, data=0xa285570, context=0xa804bb8, surface=0xb70cbd8, image=0xb6d2cc0, src_x=0, src_y=0, src_w=688, src_h=446, dst_x=0, dst_y=23, dst_w=688, dst_h=446, smooth=0, do_async=0 '\000')
    at lib/evas/canvas/evas_object_image.c:1547
#18 0xb7143cbc in _evas_image_render (eo_obj=0x4001921c, obj=0xab48b90, output=0xa285570, context=0xa804bb8, surface=0xb70cbd8, x=0, y=0, l=0, t=0, r=0, b=0, do_async=0 '\000') at lib/evas/canvas/evas_object_image.c:2069
#19 0xb714337b in evas_object_image_render (eo_obj=0x4001921c, obj=0xab48b90, type_private_data=0xab48c40, output=0xa285570, context=0xa804bb8, surface=0xb70cbd8, x=0, y=0, do_async=0 '\000')
    at lib/evas/canvas/evas_object_image.c:1898
#20 0xb71b79eb in evas_render_mapped (evas=0xa2840a8, eo_obj=0x4001921c, obj=0xab48b90, context=0xab06de0, surface=0xb70cbd8, off_x=0, off_y=0, mapped=0, ecx=0, ecy=0, ecw=776, ech=576, proxy_render_data=0x0, level=3, do_async=0 '\000') at lib/evas/canvas/evas_render.c:2256
#21 0xb71b9d49 in evas_render_updates_internal_loop (eo_e=0x40001536, evas=0xa2840a8, surface=0xb70cbd8, context=0xab06de0, top=0x0, ux=0, uy=0, uw=776, uh=576, cx=0, cy=0, cw=776, ch=576, fx=0, fy=0, alpha=0 '\000', do_async=0 '\000', offset=0xbf970b34, level=0) at lib/evas/canvas/evas_render.c:2900
#22 0xb71bb0c8 in evas_render_updates_internal (eo_e=0x40001536, make_updates=1 '\001', do_draw=1 '\001', done_func=0x0, done_data=0x0, do_async=0 '\000') at lib/evas/canvas/evas_render.c:3230
#23 0xb71bc4c3 in evas_render_updates_internal_wait (eo_e=0x40001536, make_updates=1 '\001', do_draw=1 '\001') at lib/evas/canvas/evas_render.c:3615
#24 0xb71bc5cb in _evas_canvas_render_updates (eo_e=0x40001536, e=0xa2840a8) at lib/evas/canvas/evas_render.c:3638
#25 0xb7134691 in evas_canvas_render_updates (obj=0x40001536) at ../src/lib/evas/canvas/evas_canvas.eo.c:288
#26 0xb7136c35 in evas_render_updates (obj=0x40001536) at ../src/lib/evas/canvas/evas_canvas.eo.c:905
#27 0xb308a1c3 in _drm_render (ee=0xa257358) at modules/ecore_evas/engines/drm/ecore_evas_drm.c:256
#28 0xb70c1f04 in _ecore_evas_idle_enter (data=0x0) at lib/ecore_evas/ecore_evas.c:223
#29 0xb6cddc3a in _ecore_call_task_cb (func=0xb70c193f <_ecore_evas_idle_enter>, data=0x0) at lib/ecore/ecore_private.h:283
#30 0xb6cddc9e in _ecore_factorized_idle_process (data=0xa16cc80, event=0xbf970e4c) at lib/ecore/ecore_idler.c:35
#31 0xb61b21c8 in _event_callback_call (obj_id=0x40000062, pd=0xa167a18, desc=0xb6d184fc <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0, legacy_compare=0 '\000') at lib/eo/eo_base_class.c:1422
#32 0xb61b2423 in _efl_object_event_callback_call (obj_id=0x40000062, pd=0xa167a18, desc=0xb6d184fc <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0) at lib/eo/eo_base_class.c:1506
#33 0xb61b5dbf in efl_event_callback_call (obj=0x40000062, desc=0xb6d184fc <_EFL_LOOP_EVENT_IDLE_ENTER>, event_info=0x0) at lib/eo/efl_object.eo.c:142
#34 0xb6cdda7a in _ecore_idle_enterer_call (loop=0x40000062) at lib/ecore/ecore_idle_enterer.c:48
#35 0xb6ce0ef1 in _ecore_main_loop_iterate_internal (once_only=0) at lib/ecore/ecore_main.c:2293
#36 0xb6cdf062 in ecore_main_loop_begin () at lib/ecore/ecore_main.c:1289
#37 0x0807b25e in main (argc=1, argv=0xbf9aa134) at src/bin/e_main.c:1089
(gdb)
ApB created this task.Mar 24 2017, 6:42 AM
zmike added a comment.Aug 15 2017, 1:10 PM

@ManMower isn't this a known xwayland issue?

I can't reproduce this, haven't seen anything like it.

Does this still happen?

ApB closed this task as Resolved.Jan 22 2018, 11:49 AM

I can't reproduce this, haven't seen anything like it.

Does this still happen?

The bug is older than you. :P Probably fixed.