Don't forget to figure out that set of interface for widgets
|Open||None||T7142 efl 2.0 considerations|
|Open||cedric||T5301 Make EFL easier to use by improving its interface|
|Duplicate||singh.amitesh||T5363 Cleanup elm_widget.eo|
|Open||felipealmeida||T5567 Simple factories (with or without model)|
|Open||cedric||T6360 EO: Item and Item_List API's|
|Open||thiepha||T5326 Refactor ctxpopup, popup and notify|
|Open||cedric||T5327 Refactor toolbar|
|Resolved||bu5hm4n||T5328 Refactor/rename container, pack, ... interface|
I've realised that the Efl.Container interface is stupid because:
- The name is stupid. Its methods and prefix are "content" not container :)
- It's a bad mix between single slot APIs (content_set/get/unset) and multiple children APIs (iterate, count, ...)
So this should be split into 2 interfaces. One for single slot (used in efl_content_set(efl_part(layout, "part"), subobj)) and the other used in box, table, etc...
I'm just not sure about the naming.