Page MenuHomePhabricator

IO blocking issues with udisks2, cp file to usb causes E to become unresponsive
Open, NormalPublic

Description

I was copying a couple 2GB ISOs to USB. In doing so E desktop became extremely unresponsive. I could not even SSH from another system without major delays. Same for typing and/or moving windows. This seems to be related to udisks2. Unrelated to E, when udisks2 mounted my USB drive and I tried to copy the ISO's they would never finish. The copy operation never completed. That made the issues with E last till I took action.

Now I mounted the USB drive directly as root, bypassing udisks2. I then did the same copy operation and had NO issues with E. I did the same copy under KDE using udisks2, and had no issues with blocking IO. But the copy operation never completed. The not completing is a udisks2 issue. But E definitely has some issues with blocking IO when using udisks2 mounted devices. I will file another bug on the copy operation not finishing with udisk/freedesktop.org.

dev-libs/efl-1.19.0_beta4::os-xtoo
x11-wm/enlightenment-0.21.7::os-xtoo
sys-fs/udisks-2.1.8:2::gentoo

I do not think kernel and versions of other things matter. But I can provided if needed.

Mounted via udisks2
/dev/sdf1 on /run/media/wlt/4849-D2E7 type vfat (rw,nosuid,nodev,relatime,uid=10001,gid=100,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)

Mounted as root
/dev/sdf1 on /mnt/floppy type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)

wltjr created this task.Apr 7 2017, 3:41 PM
bu5hm4n triaged this task as Normal priority.Jun 11 2018, 12:56 AM
zmike edited projects, added Restricted Project; removed efl.Jun 11 2018, 6:54 AM
q66 edited projects, added efl: system integration; removed Restricted Project.Jun 11 2018, 7:32 AM